NullPointerException: Attempt to invoke virtual method 'void java.util.Calendar.setTimeZone(java.util.TimeZone)' on a null object reference

  • developer

    Is this error reproducible? Can you provide steps to reproduce (including your system time zone and task details)? I’d need to reproduce the problem so that I can have a look at that.

  • developer


    Did you already find out which task was related?

  • developer

    For the records: We have received several reports with this exception. However, I was still unable to reproduce this issue and thus have no idea where it might come from…

    If you have any useful hints, please let us know.

    ical4j report:

  • It happens to me as well, every time it syncs this errors appears as notification.

    I have Android 8.0.

  • developer

    @dolohow Unfortunately, we still don’t have an idea what the problem could be or how it could be reproduced. Any hints are appreciated…

  • Hi,

    now i update DavDroid v1.11.1-gplay - and this issue disappear. ☺

    Below you can find the error log, from the previous version.

    • Nextloud Server v13.0.1
    • DavDroid v1.11-gplay (213)
    • Phone: Samsung S9 - v8.0.0


  • developer

    Maybe 1.11.1 fixes this problem for the others too? We haven’t changed anything about event/calendar handling in .1, but if it’s fixed – even better 😉

  • I still have the issue, with davdroid 1.11.1 galaxy S8 android version 8.0.0

    Issue 229 on github also mentions another linked issue which is still open but mentions hcalendar:-

    Mine failed on this Ical entry if useful:-

    PRODID:-// DDay.iCal 1.0//EN
    TZID:GMT Standard Time
    TZNAME:GMT Standard Time
    TZNAME:GMT Summer Time
    DESCRIPTION:Call To +445556487078\nNumber: +445556487078\nDuration: 0 secon
    DTEND;TZID=GMT Standard Time:20180418T102600
    DTSTART;TZID=GMT Standard Time:20180418T102600
    SUMMARY:Call To +445556487078

    it was working fine syncing with cpanel (horde) as the server and now I have just switched to self hosted davical 1.1.4 the problem has arisen.

  • OK I fixed my issue by adding a line to the davical config to handle the nonstandard timezone as follows:-

    $c->timezone_translations = array( ‘GMT Standard Time’ => ‘Europe/London’ );

  • developer

    Thanks. Couldn’t reproduce this on 8.0 in the emulator… I guess it must be related to time zone name, maybe because of the space? And it seems to occur in very specific images of 8.0.0 only… and it’s an Android bug, because java.text.DateFormat.setTimeZone( throws the exception, and that’s part of the Android Java library (and not in userspace, i.e. ical4android/DAVdroid)…

  • I am also having this problem. I just noticed it now, while debugging the fact that new calendar entries were not being synced from the phone to the server. I tried disabling the calendar from the sync settings (which removed all entries from the phone calendar, as expected), and then reenabling the calendar. I now have the same exception above, in one ICS entry. Syncing does not work, I am assuming the exception kills the sync process.

    I am attaching the ICS that causes the problem, as retrieved from the ownCloud server following the URL specified in the DAVDroid debug output. For some reason, the dates are all wrong, shifted by multiple decades. There must have been some corruption somewhere along the way, possibly at an earlier time. I hope it did not affect many entries.


  • @rfc2822 said in NullPointerException: Attempt to invoke virtual method 'void java.util.Calendar.setTimeZone(java.util.TimeZone)' on a null object reference:

    Maybe 1.11.1 fixes this problem for the others too? We haven’t changed anything about event/calendar handling in .1, but if it’s fixed – even better 😉

    No, I have updated to 1.11.3-gplay and the issue is still there. What’s even worse, I don’t receive a notification about the problem, it just silently stopped syncing.

    I’m using Android 8.0.0 and radicale

  • developer

    We received the information from @belidzs that the latest Android update fixed the problem.

    I guess this is an Android firmware problem and encourage everyone with this problem to update to the latest firmware version as soon as possible.

    Does upgrading Android fix this problem for other affected users here, too?

  • Hello,

    I was getting the same error message until I have checked the Contact birthdays calendar to sync in CalDAV as it was intentionally not set to sync from the very beginning.

    Right now, I am not getting that error message again, even despite that I have force closed DAVDroid and reopened it.

    Now I cannot even see my calendars anymore 😕

    I am attaching two debug logs and a screenshot.

    According to the debug log, the only difference is the sync row 0 vs 1.



    Hum, that is interesting… A basic reinstallation of DAVdroid 1.11.3-gplay was not helping, but when I have installed 1.9.9-gplay, the sync worked as expected. Then I’ve installed 1.11.2-gplay and it worked too. Then I have installed 1.11.3-gplay back, and so it has also worked.

    I am confused now 🙂 The good point that it is working now for me. (without me cleaning the brute force attempts table, see below)

    If you anyone is having the same issue while using Nextcloud or Owncloud, please try cleaning your brute force attempts table from it:

    1. stop your nextcloud/owncloud instance;
    2. backup your nextcloud/owncloud database;
    3. delete records from the brute force attempts table:
    $ sqlite3 /path/to/nextcloud/data/owncloud.db
    sqlite> BEGIN;
    sqlite> SELECT * FROM oc_bruteforce_attempts;
    sqlite> DELETE FROM oc_bruteforce_attempts;
    sqlite> SELECT * FROM oc_bruteforce_attempts;
    sqlite> COMMIT;
    sqlite> .quit
    4. start your Nextcloud/Owncloud back again and try DAVdroid to sync the Calendar again.

    Kind regards,
    Andrey Arapov

  • developer

    @arno Thanks for the update. Were there any Android/system updates in this time?

  • @rfc2822 AFAIR, there was Android OS update quiet some time ago, longer before I started to see the error message. The first time I’ve got the error message was the last week as I was traveling to Greece, so the timezone was shifted by +1 hour. That was the time I started to see the error message. Also, it might be worth mentioning, I was making a phone factory reset just a day before I traveled to Greece last week.

  • I had the same exception all of a sudden this afternoon. I updated DAVdroid to 1.11.4-beta4-ose (from F-Droid) yesterday evening, syncing flawlessly during the entire morning. Disabling and enabling claendars in DAVdroid didn’t make any difference. I also deleted the calendar storage data from the Android settings > apps, same error occurred.

    Hum, that is interesting… A basic reinstallation of DAVdroid 1.11.3-gplay was not helping, but when I have installed 1.9.9-gplay, the sync worked as expected. Then I’ve installed 1.11.2-gplay and it worked too. Then I have installed 1.11.3-gplay back, and so it has also worked.

    That’s basically what seems to have helped also for me: I uninstalled DAVdroid 1.11.1-ose (the oldest version F-Droid is offering) and synced my calendars. Then I updated to 1.11.2-ose and synced, no problem occurred. Finally I updated to 1.11.4-beta4-ose and up until now sync works like a charm.

    I hope this help aniling the culprit down.

  • I’m also experiencing this bug for the last few days. No major update of Android for the last few weeks.
    I noticed this bug was triggered when I created/updated an event on my calendar (stored on a private Owncloud).
    Is there a way to detect which event could have triggered the bug?

  • @dco The issue resolved by itself. No Android update, no Owncloud update, just moved some calendar entries further in time 😕

  • I have the same problem.
    1 SOGO server with a shared calander.

    When i make a event in de shared calander with time then i get the error.

    --- BEGIN DEBUG INFO ---
    Account name: nike @ anjo sogo
    Authority: org.dmfs.tasks
    LocalTask=[eTag=null, fileName=76d23e9f-ca05-4956-9c42-51f12599365f.ics, flags=0, id=1, task=Task=[classification=null, color=null, completedAt=null, createdAt=1531077792643, description=null, dtStart=null, due=null, duration=null, exDates=[], geoPosition=null, lastModified=1531077792643, location=null, organizer=null, percentComplete=null, priority=0, rDates=[], rRule=null, status=STATUS:NEEDS-ACTION, summary=Test3, url=null, sequence=0, uid=76d23e9f-ca05-4956-9c42-51f12599365f, shadow$_klass_=class at.bitfire.ical4android.Task, shadow$_monitor_=0], taskList=at.bitfire.davdroid.resource.LocalTaskList@4cdb1c8, shadow$_klass_=class at.bitfire.davdroid.resource.LocalTask, shadow$_monitor_=0]
    java.lang.NullPointerException: Attempt to invoke virtual method 'void java.util.Calendar.setTimeZone(java.util.TimeZone)' on a null object reference
    	at java.text.DateFormat.setTimeZone(
    	at net.fortuna.ical4j.model.Iso8601.<init>(
    	at net.fortuna.ical4j.model.Iso8601.<init>(
    	at net.fortuna.ical4j.model.Date.<init>(
    	at net.fortuna.ical4j.model.DateTime.<init>(
    	at net.fortuna.ical4j.model.DateTime.<init>(
    	at net.fortuna.ical4j.model.component.VToDo.<init>(
    	at net.fortuna.ical4j.model.component.VToDo.<init>(
    	at at.bitfire.ical4android.Task.write(Task.kt:133)
    	at at.bitfire.davdroid.syncadapter.TasksSyncManager$prepareUpload$1.invoke(TasksSyncManager.kt:83)
    	at at.bitfire.davdroid.syncadapter.TasksSyncManager$prepareUpload$1.invoke(TasksSyncManager.kt:42)
    	at at.bitfire.davdroid.syncadapter.BaseDavSyncManager.useLocal(BaseDavSyncManager.kt:296)
    	at at.bitfire.davdroid.syncadapter.TasksSyncManager.prepareUpload(TasksSyncManager.kt:78)
    	at at.bitfire.davdroid.syncadapter.TasksSyncManager.prepareUpload(TasksSyncManager.kt:42)
    	at at.bitfire.davdroid.syncadapter.BaseDavSyncManager$uploadDirty$1$1.invoke(BaseDavSyncManager.kt:142)
    	at at.bitfire.davdroid.syncadapter.BaseDavSyncManager$uploadDirty$1$1.invoke(BaseDavSyncManager.kt:37)
    	at at.bitfire.davdroid.syncadapter.BaseDavSyncManager.useRemote(BaseDavSyncManager.kt:303)
    	at at.bitfire.davdroid.syncadapter.BaseDavSyncManager$uploadDirty$1.invoke(BaseDavSyncManager.kt:140)
    	at at.bitfire.davdroid.syncadapter.BaseDavSyncManager$uploadDirty$1.invoke(BaseDavSyncManager.kt:37)
    	at at.bitfire.davdroid.syncadapter.BaseDavSyncManager.useLocal(BaseDavSyncManager.kt:296)
    	at at.bitfire.davdroid.syncadapter.BaseDavSyncManager.uploadDirty(BaseDavSyncManager.kt:131)
    	at at.bitfire.davdroid.syncadapter.SyncManager.performSync(SyncManager.kt:109)
    	at at.bitfire.davdroid.syncadapter.TasksSyncAdapterService$TasksSyncAdapter.sync(TasksSyncAdapterService.kt:64)
    	at at.bitfire.davdroid.syncadapter.SyncAdapterService$SyncAdapter.onPerformSync(SyncAdapterService.kt:97)
    	at android.content.AbstractThreadedSyncAdapter$
    Package: at.bitfire.davdroid
    Version: 1.11.5-gplay (233) from 17 jun. 2018
    Installed from:
    JB Workaround installed: no
    CONNECTIVITY (at the moment)
    Active connection: WiFi, CONNECTED
    Power saving disabled: no
    android.permission.READ_CONTACTS permission: granted
    android.permission.WRITE_CONTACTS permission: granted
    android.permission.READ_CALENDAR permission: granted
    android.permission.WRITE_CALENDAR permission: granted
    org.dmfs.permission.READ_TASKS permission: granted
    org.dmfs.permission.WRITE_TASKS permission: granted
    System-wide synchronization: automatically
    Account: nike @ anjo sogo
      Address book sync. interval: 240 min
      Calendar     sync. interval: 15 min
      OpenTasks    sync. interval: 240 min
      WiFi only: false
      [CardDAV] Contact group method: GROUP_VCARDS
      [CalDAV] Time range (past days): 90
               Manage calendar colors: false
    	|  locale |
    	|  nl_NL |
    	|  _id | accountName | service | principal |
    	|  2 | nike @ anjo sogo | carddav | |
    	|  3 | nike @ anjo sogo | caldav | |
    	|  name | seq |
    	|  services | 3 |
    	|  homesets | 4 |
    	|  collections | 10 |
    	|  _id | serviceID | url |
    	|  3 | 2 | |
    	|  4 | 3 | |
    	|  _id | serviceID | type | url | readOnly | forceReadOnly | displayName | description | color | timezone | supportsVEVENT | supportsVTODO | source | sync |
    	|  7 | 2 | ADDRESS_BOOK | | 0 | 0 | Persoonlijk adresboek | <null> | <null> | <null> | 0 | 0 | <null> | 0 |
    	|  8 | 2 | ADDRESS_BOOK | | 0 | 0 | Domain Address Book | <null> | <null> | <null> | 0 | 0 | <null> | 0 |
    	|  9 | 3 | CALENDAR | | 0 | 0 | Persoonlijke agenda | <null> | -5592406 | <null> | 1 | 1 | <null> | 0 |
    	|  10 | 3 | CALENDAR | | 0 | 0 | Rene & Anjo | <null> | -5592406 | <null> | 1 | 1 | <null> | 1 |
    Android version: 8.0.0 (R16NW.G930FXXU2EREM)
    Device: samsung SM-G930F (herolte)
    --- END DEBUG INFO ---

    I removed my domain.
    I have a samsung galaxy S7 with android 8.0.0

Similar topics