Contacts disappear on a BB Motion when deselecting accounts in BB Contacts app



  • Hey all,

    My NextCloud contacts are synced via DavDroid, I am not sure if this is somehow related. I'm on Nextcloud v13.0.1 and am using a BB Motion with Android 7.1.2 - DavDroid debug info see here: Debug info

    I am having issues with the BB Contacts app. As you can see in the screenshots, when I have all accounts active (checkboxes ticked), all the contacts are there (numbers are correct). But as soon as I deselect one account (even the empty BBM one), the number of visible contacts decreases for my DavDroid - synced NextCloud account. For example, I have got 261 contacts in my NextCloud account. Everything is fine when all my accounts are selected in the settings and thus visible. When I tick off the checkbox for the the BB account, even though there are no contacts related, the number of NextCloud contacts decreases. Same happens when I make any other account invisible. When I revert to activating all other accounts, everything is fine again.

    EDIT: For testing, I have deleted all my Google contacts (want to get rid of Google anyways) and have synced that with my BB - Google contacts are now at zero, while NextCloud contacts stay at 261, as long as I leave all accounts activated / visible.

    EDIT: A strange thought comes to my mind. I have imported my Google contacts into NextCloud - the 2 remaining contacts were added for testing purposes before importing stuff into NextCloud and syncing. Now, it's strange that these 2 contacts remain when ticking off.

    EDIT: Just as I deleted all my Google contacts, when I now tick off the BBM contacts checkbox, not even these 2 contacts remain for NextCloud. In NextCloud itself, and as soon as I tick all checkboxes to make all accounts visible, everything is fine again.

    I'm going to get rid of Google and am wanting to delete anything Google-related (as far as possible) on my mobile phone. Now I'm a bit anxious of what will happen then if this issue still remains.

    Does anybody have a clue?

    Screenshots:

    0_1523540631670_1.gif

    1_1523540631672_2.gif

    Best regards
    Dennis


  • developer

    Hello,

    Do you think this is a DAVdroid problem? Did yoo already contact Blackberry support about that?


 

Looks like your connection to Bitfire App Forums was lost, please wait while we try to reconnect.