Synology Diskstation & Baikal - DAVdroid won't create an account



  • Hello there!

    After days of searching the internet I'm giving up: I set up Baikal on my Synology Diskstation, but DAVdroid won't create an account...
    As basic-URL I tried
    https://[myDS].synology.me/baikal.app/card.php/
    http://[myDS].synology.me/baikal.app/card.php/
    https://[myDS].synology.me:443/baikal.app/card.php/
    http://[myDS].synology.me:5005/baikal.app/card.php/
    https://[myDS].synology.me:5006/baikal.app/card.php/
    https://[myDS].synology.me:5001/baikal.app/card.php/
    http://[myDS].synology.me:5000/baikal.app/card.php/

    The resource-recognition (Ressourcen-Erkennung) is either calling the server-information for hours or I get the message

    "Ressourcen-Erkennung - Es konnte weder ein CalDAV- noch ein CardDAV-Dienst gefunden werden" (Neither CalDAV nor CardDAV service could be found)

    In the protocol it says:
    [HttpClient] <-- 405 Not Allowed http://[myDS].synology.me:5000/baikal.app/card.php/

    At least http://[myDS].synology.me:5000 is accessible through my browser.

    Do you have any ideas? Thanks for helping!


  • admin

    Did you try the standard CardDAV and Calendar package of Synology DSM?

    Did you have a look at our help pages for Baikal and Synology already?

    https://www.davdroid.com/tested-with/synology/
    https://www.davdroid.com/tested-with/baikal/



  • Thanks for the quick answer. Already tried the help pages for Baikal and Synology.

    Just installed CardDAV and Calender

    Tried CardDAV:

    http Ports 5000, 5005
    No CalDAV or CardDAV service found, the protocol says:
    '''<-- HTTP FAILED: java.net.ConnectException: Failed to connect to [myDS].synology.me/77.21.240.22:5005'''

    with
    http Port 8008
    https Ports 5001, 5006, 8443
    there is also no success: The resource-recognition is just in the server-information-calling-loop

    Calender:
    WORKS with http Port 5000
    doesn't work with https Port 5001:
    '''HTTP FAILED: java.net.SocketTimeoutException: failed to connect to [myDS].synology.me/77.21.240.22 (port 5001) after 30000ms
    [ui.setup.DavResourceFinder] PROPFIND/OPTIONS on user-given URL failed'''

    Baikal:
    Still Error
    '''[HttpClient] <-- 405 Not Allowed http://[myDS].synology.me/baikal.app/dav.php/'''


  • admin

    I have no other suggestions, sorry... Here it works out of the box with CardDAV and Calendar packages. Maybe you need to look at the SSL certificates or so...


  • admin

    Did you make sure not to enable the WebDAV package?



  • WebDAV is turned off... So it should rather be a problem with synology, right? I'll post in their forum and report here after. Thanks anyway!


 

Looks like your connection to Bitfire App Forums was lost, please wait while we try to reconnect.