Cannot turn off "Force read-only"



  • Hi,
    I am facing the following problem. In my DavDroid app all CalDav and CardDav items have force read-only mode on since last update. I cannot remove it, since everytime i click on it I am send back to the main menu. It is pretty annoying since I am not able to create events in my calendar nor can I change items in my contacts.
    I haven't found a similar issue yet. My server is running nextcloud, but I believe it has nothing to do with the server, since force read-only is a new future that is working on the app?!

    Best regards,
    Martin


  • developer

    See https://forums.bitfire.at/topic/1574/davdroid-1-9-release-notes/4:

    Please note that if you upgrade from v <1.9 to 1.9.4 ≤ v < 1.9.10 directly, the upgrade will still fail (causing all collections to be shown as read-only without possibility to change that).

    Unfortunately, the only solution is:

    In this case, you have to uninstall DAVdroid and install it again (or to delete all DAVdroid accounts, clear app storage and add the accounts again).

    Sorry for the inconvenience. This won't happen if you update from any DAVdroid version to 1.9.10 or later.



  • Thanks! I hope it won't cause too many struggles. I am quite confident that your solution will work! So let's see this problem as solved 🙂