ICS Droid sets sync interval to "manual"



  • Dear all,
    using ICSDroid on my Samsung Galaxy A5 (2017) with Android 7.0 and "Samsung Experience 8.1." for a while now to sync a calendar.

    For several months now, it seems like ICSDroid is "resetting" the sync interval to "manual". Every time I set it two say "two hours" it works as expected for a week or so, then all of a sudden I realize that that the interval is set to manual without me changing it.

    Can someone help?


  • developer

    Did you try to whitelist ICSdroid from "battery optimization"?


  • developer

    We have found that "Maximum power saving mode" resets app sync intervals.

    Can you have a look at https://www.davdroid.com/faq/automatic-synchronization-is-not-run-as-expected/#c249 (Maximum power saving mode) and tell us whether this describes/solves your problem?



  • @rfc2822
    I have icsdroid 1.5.4 on android 7.1.2 (Resurrection Remix ROM) on ZTE Axon 7 hardware. When I try to save the sync interval, I receive a message "Autosync disabled". I have not found a way to set the interval or to even manually get icsdroid to sync (to a calendar feed without need to login). I have removed icsdroid from battery optimization (set to "not optimized"). App has calendar permissions. Even when I also give storage permission, it still does not save the autosync interval. What else can I do?


  • admin

    Maybe you can look into the Android Settings / Accounts / ICSdroid and maybe there is an option to enable Auto-Sync...

    ROMs are very different sadly - everybody is cooking its own soup so we don't know all devices. In the basic unbranded Android there is a sync button in task navigation - maybe you have it too and it is switched off.


Log in to reply
 

Looks like your connection to Bitfire App Forums was lost, please wait while we try to reconnect.