icsdroid 1.5 doesn't transfer data

  • Hello,
    I had to do a factory reset on my S8+. icsdroid was restored and setup of the calendar-URL worked.
    Icsdroid shows the right calendar name so I think, the connection works fine.
    But the calendar will not be transferred to the calendar on my mobile, icsdroid tells me "noch nicht übertragen" (not yet transferred) and stays in this state since several days.
    De- and reinstallation shows the same issue.

    What goes wrong?

    Thanks for your help,


  • admin


    did you grant the necessary permissions? Did you pull down the screen (where the calendars are listed) to force a manual sync?

  • developer

    What happens if you swipe down / force sync?

  • @devvv4ever and @rfc2822
    By reinstalling icsdroid the programm asked for permission to access calendar, I granted it. In android I found the possibility to grant access to memory too, no effect.
    Swiping down / actualisation seems to work (a short time activity, no error message), but icsdroid remains with "noch nicht übertragen".

  • developer

    Have you tried other calendars, for instance from webcal.fi? Is this problem reproducible on other devices? Can you tell us the calendar URL?

  • @rfc2822
    The same calendar works fine with icsdroid on my tablet.

  • admin

    Please give us steps to reproduce it. We need much more details about all this (Phone type, Android version, the ics file itself or an URL and so on...). Without being able to reproduce it we can't do anything.

  • Samsung S8+
    Android 7.0

    For the ics-file: I wouldn't publish the file / url to the world, where can I send it to you personally?

  • admin

  • Ok,
    I've mailed the file.
    By the way: yesterday came an update to version 1.5.2, now I get a red error message:
    "Couldn't parse iCalendar ressource"

  • developer

    This should be fixed by ical4android/4604c15f. I have sent you an APK, please tell me if it's working for you.

    Additionally, https://github.com/ical4j/ical4j/issues/207 has been reported.

  • @rfc2822


    Now it works fine.

    Thanks for your help!

  • same problem here. not able to sync. where can i find your .apk?

  • admin

    @colognaut which version of DAVdroid do you have currently?

  • Same problem here:
    The subscription seems to work, but it says "not syncronized yet". I can't force it to syncronize (by swiping down) and I can't set an update interval.
    The subscription is not shown in "Settings -> accounts". Adding an account -> ICSdroid leads to the Icsdroid-setup-wizard, I already went through.
    I can't send you the url (and username) of the calender in question because my employer wouldn't like that. I can download the calender with "Calender Import-Export" and I tried icsdroid with public calenders from webcal.fi (same problem there).
    I'm using icsdroid 1.5.4 and running Ressurection Remix 5.8.5 (Android 7.1.2). I tried uninstalling/reinstalling. Battery optimization is turned off. I just updated the OS and before that everything was super smooth (thanks btw for that great app), so I'm hoping that it's a configuration problem over here. Any help is highly appreciated!

  • Update: I just redid the OS-update and now everything works fine. I guess there was some disturbance due to my attempts of restoring backup-data.


Looks like your connection to Bitfire App Forums was lost, please wait while we try to reconnect.