Automatic synchronization not run on Blackview BV6000s

0

Hi,

I've just purchased a Blackview BV6000s and found that DAVdroid synchronization is not run. Manually running the synchronization works as expected (I've been using it in an Android 4 device for more than a year without any problem at all).

I've read the following articles on the FAQ but I'm unable to find equivalent menu options in my phone:

At the end of the message is the anonymized output of the debug info file generated by DAVDroid.

My smartphone is running Android 7. My wife's phone is having the exact same issue with Android 6.

How can I solve this problem?

Thank you,

Guillermo

--- BEGIN DEBUG INFO ---

SOFTWARE INFORMATION
Package: at.bitfire.davdroid
Version: 1.9-gplay (182) from Oct 15, 2017
Installed from: com.android.vending
JB Workaround installed: no

CONNECTIVITY (at the moment)
Active connection: WiFi, CONNECTED

CONFIGURATION
Power saving disabled: yes
android.permission.READ_CONTACTS permission: granted
android.permission.WRITE_CONTACTS permission: granted
android.permission.READ_CALENDAR permission: granted
android.permission.WRITE_CALENDAR permission: granted
org.dmfs.permission.READ_TASKS permission: granted
org.dmfs.permission.WRITE_TASKS permission: granted
System-wide synchronization: automatically
Account: XXXXXX
Address book sync. interval: 15 min
Calendar sync. interval: manually
OpenTasks sync. interval: 15 min
WiFi only: true, SSIDs: [XXXXXX]
[CardDAV] Contact group method: GROUP_VCARDS
[CalDAV] Time range (past days): 90
Manage calendar colors: true
Address book account: XXXXXX (XXXXXX Pg)
Main account: Account {name=XXXXXX, type=bitfire.at.davdroid}
URL: ...
Sync automatically: true

SQLITE DUMP
android_metadata
| locale |
| en_US |

services
| _id | accountName | service | principal |
| 1 | XXXXXX | carddav | XXXXXX |
| 2 | XXXXXX | caldav | XXXXXX |

sqlite_sequence
| name | seq |
| services | 2 |
| homesets | 5 |
| collections | 11 |

homesets
| _id | serviceID | url |
| 1 | 1 | XXXXXX |
| 2 | 2 | XXXXXX |
| 3 | 2 | XXXXXX |
| 4 | 2 | XXXXXX |
| 5 | 2 | XXXXXX |

collections
| _id | serviceID | type | url | readOnly | displayName | description | color | timezone | supportsVEVENT | supportsVTODO | source | sync |
| 1 | 1 | ADDRESS_BOOK | XXXXXX | 0 | XXXXXX | <null> | <null> | <null> | 0 | 0 | <null> | 1 |
| 2 | 2 | CALENDAR | XXXXXX | 0 | XXXXXX | <null> | -1988439 | <null> | 1 | 1 | <null> | 1 |
| 3 | 2 | CALENDAR | XXXXXX | 0 | XXXXXX | <null> | -5131855 | <null> | 1 | 1 | <null> | 1 |
| 4 | 2 | CALENDAR | XXXXXX | 0 | XXXXXX | <null> | -327843 | <null> | 1 | 1 | <null> | 1 |
| 5 | 2 | CALENDAR | XXXXXX | 1 | XXXXXX | <null> | -5709398 | <null> | 1 | 1 | <null> | 1 |
| 6 | 2 | CALENDAR | XXXXXX | 0 | XXXXXX | <null> | -5717279 | <null> | 1 | 1 | <null> | 1 |
| 7 | 2 | CALENDAR | XXXXXX | 0 | XXXXXX | <null> | -1974104 | <null> | 1 | 1 | <null> | 1 |
| 8 | 2 | CALENDAR | XXXXXX | 0 | XXXXXX | <null> | -37376 | <null> | 1 | 1 | <null> | 1 |
| 9 | 2 | CALENDAR | XXXXXX | 0 | XXXXXX | <null> | -12032 | <null> | 1 | 1 | <null> | 1 |
| 10 | 2 | CALENDAR | XXXXXX | 0 | XXXXXX "in" | <null> | -1979736 | <null> | 1 | 1 | <null> | 1 |
| 11 | 2 | CALENDAR | XXXXXX | 0 | XXXXXX | <null> | -13893636 | <null> | 1 | 1 | <null> | 1 |

SYSTEM INFORMATION
Android version: 7.0 (BV6000S_T_BLACKVIEW_20170605)
Device: Blackview BV6000S (BV6000S)

--- END DEBUG INFO ---

0

Hello Guillermo,

I don't think this is a DAVdroid but a general "issue" of Android nowadays... Maybe you need to dig into the depths of your phones battery optimization features. I myself had to add DAVdroid additionally to the "Unmonitored apps" list. Then the automatic sync is working without problems.

Another thing that often prevents automatic sync is a firewall, anti virus or privacy guard app. Also some network misconfiguration or proxy settings can be a problem for automatic sync.

One must still have chaos in oneself to be able to give birth to a dancing star. – Friedrich Nietzsche

Log in to reply

Looks like your connection to Bitfire App Forums was lost, please wait while we try to reconnect.