CardDAV not working with Telstra Mail



  • I think there is a problem with the Telstra Australia CardDAV server, but I would like to confirm that and my understanding of what is wrong before tackling them.

    I think I have read everything except the CardDAV standard, and searched everywhere. It is possible that not many people use CardDAV with Telstra Mail, which was newly implemented last year, so no one has found and fixed the issue.

    I use Outlook 2010 as my primary Calendar and Contacts database.
    I sync these to Telstra Mail using the "CalDav Synchonizer" plugin.
    All my Calendar and Contacts information appears in the Telstra Mail web client.
    I have a Samsung S5 mobile running Android 6.0.1.
    I installed DAVdroid and set up both Calendar and Contacts accounts using the URL plus User and Password method. CalDAV works fine, showing Calendar items in the Samsung App, "S Planner" (although not in Outlook on the phone, but that is another issue).
    When I create a CardDAV account I cannot get DAVdroid to find a Contacts collection and add it to the account. I have deleted accounts and recreated them, including just creating a CardDAV account. Refreshing the Address Book List does not add my "main" address book to the account.

    The primary URL addresses Telstra supplies are;
    · CalDAV server: calendar.telstra.com
    · CardDAV server: contacts.telstra.com
    From here: https://www.telstra.com.au/support/category/email/set-up/set-up-telstra-mail-on-your-device
    I believe that this means that I need to set up two accounts, one for Calendar and one for Contacts, as the Collections are not both under the one URL.

    A created a log by turning it on in settings and then simply running the "Refresh address book list" function. Nothing more, because without an address book listed under the account, nothing will sync anyway.

    From the log file:
    The principle URL for Contacts is expanded to;
    https://contacts.telstra.com/carddav/principal/XXXXXX%40bigpond.net.au
    (I have replaced my email address with XXXXXX here and in the attached log.)

    However the addressbook-home-set is shown as;
    <C:addressbook-home-set><D:href>/carddav/principal/XXXXXX%40bigpond.net.au/addressbooks</D:href>
    So the "%" has been replaced with "%" in the URL.
    Shortly after that in the log I get;
    <D:status>HTTP/1.1 404 Not Found</D:status>
    Is this why a Collection isn't added to the account?
    There doesn't appear to be anything else wrong in the log. But I don't know what to look for. There is no error message. The at.bitfire.davdroid:sync process is killed at the end.

    Please comment on what my next steps should be. I thought installing and using DAVdroid would be easy! :)

    Thank you.

    Oops. Uploaded the correct files. Okay, your forum keeps reverting to the incorrect files uploaded earlier, even though I deleted them, changed their names, and re-uploaded.
    I'll post the files in a new message.




  • developer

    This post is deleted!

  • developer

    @roderickgi Seems the server sends unusual responses (href of reply not matching href of request), but DAVdroid should be able to work around that and seems to have failed.

    I have sent an APK for testing over email. Please tell me whether it works with that.



  • Thanks you for the quick reply and support Ricki.

    The APK you sent installed fine and works as expected. I now have all my Contacts visible in both the Contacts, Phone and Email Apps on Android. Updates to Contacts on Android sync back to Telstra Mail and hence to MS Outlook on my PC as well. Excellent. (Although I only did one test, and only added a note to a Contact.)
    EDIT: I tested Contacts some more, and two way synchronisation seems to be working for all major fields. I did the following:
    Created a contacts in Contacts on Android. Synced via Telstra.
    Updated the contact in Outlook on PC. Synced via Telstra.
    Updated the contact in Contacts on Android. Synced via Telstra.
    Checked the contact in Outlook on PC. Synced via Telstra.
    Everything worked fine.

    I assume that this fix will be in the Google Play Store at some time in the future, so that I can get back onto the upgrade cycle with DAVdroid? Obviously I can't upgrade from the store until the fix is included.

    I also have my Calendar visible in the "S Planner" App after setting up that DAVdroid account again. I had an issue with that not setting times correctly until I realised that Telstra had set the Android Time Zone to "Lord_Howe" instead of Australia/Sydney (Eastern Time Zone). Both Time Zones are currently in Daylight Saving Time, just to confuse matters. Manually selecting the "Eastern Daylight Time" zone made things better. I'm still getting errors when syncing a Calendar Event which was created on the PC in MS Outlook, successfully synced to Android via Telstra, edited in Android, and then I try to sync the change back to Telstra. The sync from Android to Telstra fails. I have attached a Debug file here. 0_1508469211365_Calendar Event update on Adroid fails to sync back to Telstra - debug.txt
    The Daylight Saving info seems to be incomplete, and then DAVdroid gets an EXCEPTION.

    Unfortunately my Contacts and Calendar still don't turn up in Outlook for Android and I'm having quite a hard time finding out why. It seems Outlook uses different storage location (stores in Android?) for Contacts and Calendar, but it is supposed to be possible to synchronise the default Contacts and Calendar stores to Outlook. I just can't make that happen without Android wanting to sync my Microsoft or Google accounts, which would get the wrong result.

    Anyway, that isn't your problem. But any hints would be appreciated! :)

    Thanks again for the fast support. Your fix works fine.
    Rod

    PS: Sorry for the verbose post. Just working through the issues.



  • Hi RoderickGI,

    Did you get a response to your query from DAVdroid? I have seen very similar issues and raised a ticket for calendar unable to sync when created in android. Anything created remote to DAVdroid (PC's using outlook, etc) work and sync fine. I am not using DAVdroid for contacts right now and will not attempt this until the calendar is working correctly.
    From the response I received from DAVdroid, it appears to be a fault in their server okhttp, not Telstra.

    BTW, how come you item is marked resolved, yet their is no obvious resolution listed??

    Lowway



  • G'Day Lowway,

    No, I didn't get a response or solution to the problem when I create or edit a Calendar event on Android, and it won't sync back to Telstra and hence to my PC. I am still getting error messages from DAVdroid on my Android phone.

    As I create most Calendar events on my PC it hasn't been a great problem, but I do want it fixed. However I seem to have asked too many questions in one thread, so this one hasn't been looked at. Bitfire marked the thread as Solved, not me.

    I was going to start a new thread just on this specific issue but haven't had a chance to get back to it. Frankly, with the extra work required to support a Telstra based Email, Contacts, and Calendar system, which doesn't support Tasks anyway, I am thinking of moving away from the Telstra Email, and using either Outlook.com or Google Gmail, both of which can support full synchronisation with Outlook 2010 on my PC ( I think). But I have to work through some issues before doing that.

    Contacts syncing is working fine now. Note that there have been quite a few updates to DAVdroid on my phone, so I assume the fix for Contacts has been incorporated into the main program updates.

    PS: I just read your thread, and I see they know what the problem is. I also suspect that there is no point trying to get Telstra to fix the issue at their end, as they likely wouldn't do anything. This would affect all Telstra customers, of which there are many using the Telstra Email. I also see that rfc2822 has commented on the GitHub thread just 3 hours ago, probably due to your thread. So maybe a fix will be forthcoming. I hope so.


Log in to reply
 

Looks like your connection to Bitfire App Forums was lost, please wait while we try to reconnect.