ICSdroid 1.4 no longer updating calendars?

  • I have two calendars:

    added them normally in ICSDroid (first was added with 1.3 and says it updated 24.8.2017, while second was added with 1.4 and says “not synchronized yet”), but they won’t update. Sync interval was set to 4h, changed to 5min and still no update. Tried pulling down to force manual sync, I get rotating circle which doesn’t go away. Rebooting doesn’t help.

    ICS URLs both fetch quickly (about 1 sec) from browser and validate OK at http://severinghaus.org/projects/icv/ and one using HTTPS (with valid LE certificate) and another is plain HTTP.

    I’m using ICSDroid 1.4 from F-droid. It used to update work fine with ICSDroid 1.3. OS is cyanogenmod 12.1 on LG G3.

    Didn’t see anything related in forum nor in FAQ.

  • developer

    Unfortunately, I can’t reproduce the problem here. Added both calendars and they’re synced correctly.

    Did you try to uninstall ICSdroid and install it again? Maybe there was a migration problem to 1.4 (permissions or something like that).

  • I uninstalled and installed again, and it still didn’t work. Rebooted again and still not luck. I’ve checked Cyanogenmod’s “Privacy Guard” and it says everything is allowed. Android Sync icon in toolbar is also enabled.

    Then I tried going to Settings / Developer options / Development tools / Sync Tester; choose “com.android.calendar - at.bitfire.icsdroid” registered sync adapted, did “bind” (which said “Connected to Sync Adapter / authority: com.android.calendar / account type: at.bitfire.icsdroid”) and then “start sync” which said “starting sync” and after a few seconds “Sync succeeded: SyncResult: stats [ numSkippedEntries: 6]”. After that I did “unbind”.

    Now when I start ICSdroid it works - pulling down in ICSdroid to force manual sync does update timestamps of calendar feeds after few seconds (previously it just hung there with rotating circle for minutes until I got bored and closed app). Even after I reboot it still works, so I consider it fixed.

    Maybe manual method from developer tools cleaned up some stale locks or something (I’m not android developer as you can see, just pulling parallels from UN*Xoid world) ?
    Anyway just to let you know if similar problem pops up in the future. If you want me to run some tests if it happens again, let me know, I’d be glad to help. And thanks for this great piece of GPL software!

  • admin

    @mnalis you’re welcome!

    Thanks for sharing your solution. It is always good to write it here so other are pointed to a possible solution. However we’ve not had a similar one yet (afaik). Maybe the Android storage was somehow broken, and was re-initialized. At least you found a way how it works again 🙂

Similar topics