Nextcloud calendar write permissions doesn't update in DAVdroid



  • I've used DAVdroid for a while in combination with my own Nextcloud server. Works perfectly fine: I have an overview of my own and shared calendars on my phone and sync as expected.
    I just changed in Nextcloud the permissions of a shared calendar, so that I can now also edit that shared calendar. It works in the Nextcloud web-interface. However, when I sync in DAVdroid, or Etar (my calendar app), then the permissions don't get updated. In other words, in DAVdroid I still get the ⛔ icon.

    Instead I suspected that I now should get write access to that calendar (I guess removing & again installing the account works, but just wanted to check first).

    DAVdroid debug info

    Thanks :)


  • admin

    Right beside the CardDAV section in your DAVdroid account is a little option bar. Click it and refresh your collections to update the settings of it. After it the "read only" flag should be removed.

    Hope it helps :-)



  • Oh, thanks. That worked. I assumed the general sync would work as well.


Log in to reply
 

Looks like your connection to Bitfire App Forums was lost, please wait while we try to reconnect.