calendar synchronization failed (with birthdate 1905)



  • I used DavDroid for months without problems but now the calendar synchronization keeps failing. I suspect that the reason might be a too old birthdate (year 1905). The birthdate is not true and I changed it to year 2000 but the synchronization error still keeps showing after every synchronization attempt. See the debug log: 0_1496398930267_debug.txt

    Any help would be much appreciated.

    My environment:
    ownCloud 9.1 (previous ownCloud 9.0 had the same error)
    DavDroid 1.5.2-ose


  • developer

    As far as I know, the birthday calendar is read-only. Are you sure that OwnCloud allows editing birthdays this way? I guess you should edit the contact instead.

    Also, the server reported a 404 on a PUT, so this seems to be a server problem (assuming that /remote.php/dav/calendars/jan/contact_birthdays/ is a valid collection).



  • Yes, the birthday calendar is read-only and I did edit the contact's birthday (that is what I meant actually). I verified through the web client that the new birthday has made it to the server. What can I do to stop the error from appearing again?


  • developer

    @janx DAVdroid can recognize read-only calendars, and the NC/OC birthday calendar is usually detected as read-only. It seems your server didn't report the birthday calendar as read-only, and I can't know why. If you disable the birthday calendar in DAVdroid, then sync, then enable it again and sync again, the specific upload error should be gone.



  • @rfc2822 Yes, this solved my issue. Thank you very much.


Log in to reply
 

Looks like your connection to Bitfire App Forums was lost, please wait while we try to reconnect.