Reduce notifications about unknown cert.



  • Hello!

    When traveling, one often encounters captive WiFi portals (Deutsche Bahn mostly, in my case). Because these often somehow provide their own custom certificate, DAVdroid correctly produces a warning notification about this.

    I'm not sure whether it's just me, but that notification can not be swiped away. I have to click on in, scroll down and click "Reject" to make it go away. Of course, I never want to accept such a cert for one of the calendars or contact syncs that I have configured in DAVdroid.

    I wonder whether this could be automated somehow. Maybe with a general setting like "silently reject unknown cert's", which might also require a special settings entry like "review rejected cert's"? Or with a UX change to enable swiping such a notification away?



  • I would like to request the same enhancement.
    If I am on public wifis with a "Captive Portal" for login, I always get the notification that I explicitly need to open and reject the certificate.

    Can you make the notifications reject by swiping them away?


  • developer

    Thanks for your suggestions.

    Certificate notifications have been improved (cert4android/96ec2b6f)

    • don't remove notification on timeout (it's better to have a useless captive WiFi notification than potentially not being notified about a change in your own server's certificate, e.g. LetsEncrypt)
    • show certificate subject in notification sub-text (see screenshot)
    • reject certificate temporarily when notification is swiped out
    • show toast when certificate is rejected temporarily (= until the DAVdroid process is killed or certificates are reset in DAVdroid settings)

    0_1500642372959_cert1.png 0_1500642375844_cert2.png



  • Awesome work, thanks so much! I just send you some money via PayPal as a small thanks.


Log in to reply
 

Looks like your connection to Bitfire App Forums was lost, please wait while we try to reconnect.