Fastmail, couldn't find services



  • Greetings,

    Having troubles syncing with Fastmail... I created a new app password via Fastmail's settings specifically for Davdroid and tried to login using my credentials. I get:

    "Couldn't find CalDAV or CardDAV service"

    I am using a paid Fastmail account. Both DAV services should be available to me. I have used DAVdroid to sync my phone with Fastmail for over a year. I also tried to sync on an older phone and that was unsuccessful as well.

    Thank you (log link below)

    debug.txt

    not sure if this next link will be useful but here it is so you don't have to go looking
    fastmail server names and ports


  • developer

    There seems to be a problem with your DNS resolver (or the SRV records were temporarily down):

    2017-05-03 22:07:22 397 [ui.setup.DavResourceFinder] Looking up SRV records for _carddavs._tcp.fastmail.com
    2017-05-03 22:07:37 397 [ui.setup.DavResourceFinder] Didn't find carddav service, trying at https://fastmail.com:443
    

    Here:

    $ host -t SRV _carddavs._tcp.fastmail.com
    _carddavs._tcp.fastmail.com has SRV record 0 1 443 carddav-d277161.fastmail.com.
    

    It should work with these settings: https://davdroid.bitfire.at/configuration/fastmail/

    Can you try this with your connection? Can you try another connection type (WiFi/mobile)?



  • This post is deleted!


  • OK, it synced via 4G. Thank you for your help :trumpet:


  • developer

    @MrGutsy It should be possible to set up the account with the working connection (4G) and then sync over WiFi, too.



Looks like your connection to Bitfire App Forums was lost, please wait while we try to reconnect.