[bug] unicode in event name causes sync to fail

  • I’ve only tested this with emoji event names, but I noticed this when I tried to sync my NextCloud events to a new phone. Though given the error I anticipate this will probably occur with other names that have unicode in them. Oddly I remember that I added the unicode characters on my phone (which was then synced to NextCloud by DavDroid) so it looks like the sync issue is one-way only? Attached is the (redacted) debug log that DavDroid spat out.

  • developer

  • @rfc2822 I am using PostgreSQL as my database for NextCloud. If you’d like I can post my NextCloud server configuration, though I’m not sure how much it will help you.

  • developer

    @cyphar Is there any indication that this could be a client problem? If not, I suggest to ask in the Nextcloud forums. This seems to be a server problem, because DAVdroid is completely UTF-8-compatible.

  • @rfc2822 The server outputs the Emoji correctly if I go to the web ui. When I removed the emoji from the calendar (in the web ui) sync started to work again – and as far as I can tell there’s no indication in either of the logs (database / NextCloud) that it’s a server-side issue (no errors related to encoding). Plus the fact that the server let me add and remove Emoji from the event names without error doesn’t inspire confidence.

    But sure, if you feel that it’s a server-side issue I’ll post an issue there and we’ll see what they say.

  • developer

    Can you post the (anonymized) contents of https://<MYSERVER>/remote.php/dav/calendars/cyphar/personal/20170328T043130Z-b7a4412112827313.ics?

  • @rfc2822 Attached is the contents. The two [redacted] values are the same, and the Emoji character is clearly displayed (I had to edit the file in Vim but I’m fairly sure that wouldn’t mangle such things).

    I just tried to reproduce this by creating a new event that has emoji characters in it and syncing with DavDroid and it suddenly started working again. So I’m not really sure why it was broken before…

  • developer

    @cyphar Guess it’s related to the alarm and some invalid value with T0 in it…

Similar topics

  • 5
  • 2
  • 3