Lineage <-> Contacts <-> DavDroid <-> Owncloud freezes



  • Hi,
    yesterday I've installed Lineage OS on my oneplus one. Up til then I had CM13 running, with the same setup:
    Android <-> Contacts / Calendar <-> DavDroid <-> OwnCloud

    What works is:
    Android <-> Calendar <-> DavDroid <-> OwnCloud

    The Android <-> Contacts <-> DavDroid <-> OwnCloud path I can (assumingly succesfull) configure in DavDroid, but the connection to the contact app is broken.

    What I do is:

    • open contacts
    • select "Add account"
    • The "Add account" window opens, offering me
      -- "DavDroid addressbook" and
      -- "Exchange" options.
    • Selecting "DavDroid addressbook" instantly brings me back to the contacts app.
    • Opening the android task switcher shows that there is an empty/frozen "Add account" task. This task has a frame with a title, but the frame is completely transparent on the inside.
    • Selecting this empty task brings it to the foreground, but completely without title, frame or content. It is not possible to do anything. It just transparently shows the background.

    I've started the davdroid logging, but the logging output only shows normal stuff like the sqlite dump. No error messages.

    I actually don't know if it is a lineage of davdroid problem. Would be nice if you could have a look at it.


  • developer

    Is there any privacy guard or similar things active?



  • I have exactly the same problem with lineage OS, transparent frame when I want to add a davdroid account in contacts app, i have the same problem on CM 13.
    So i will stay on 1.4.1 for the moment. Thank you for this app !



  • @rfc2822 I have the same issue with 1.5-ose on LineageOS. I disabled privacy guard for DAVDroid before launching it the fist time, and adding a davdroid account to contacts still failed.

    Redoing the exact same procedure with 1.4.1-ose instead worked, and the contacts app now has the davdroid account.

    As soon as the first sync has worked I'll try upgrading to 1.5-ose.



  • @spanezz I've upgraded to 1.5-ose and it still works. I guess the work-around for this issue is to install 1.4.1-ose for the first setup, and then upgrade to 1.5-ose.

    Good, now I have contacts sync again. This fixes the biggest issue my phone still had after reinstalling with LineageOS.



  • Hi,
    in general privacy guard is active on this phone. But I've completely deactivated it for DavDroid. I've uploaded the logfiles from davdroid.

    0_1491137524673_logziles.tgz
    [Update: In the logfiles I've replaced the urls with xx.yy.zz]



  • @spanezz Thanks for the tip! Deinstalled 1.5-ose, installed 1.4.1 and everything works again!


  • developer


Log in to reply
 

Looks like your connection to Bitfire App Forums was lost, please wait while we try to reconnect.