It seem that there are all contacts gone after update to 1.5.0.1-gplay



  • After the automatic update via gplay to 1.5.0.1-gplay (or that's at least the reason i think - there was no reboot or similar, only the automatic update) there are no contacts displayed in my contacts browser (com.google.android.contacts) :/

    Unfortunately I've synced my contacts the last time about three weeks ago. So there are contacts stored on the phone that are not synced to my nextcloud server. Is there a way to get back some important unsynced contacts.
    I've already backed up the /data/data/com.android.providers/databases directory with the sqlite databases, but there i cannot find any contacts that were stored in my nextcloud account and synced with davdroid...

    As I'm not able to upload the debug.txt as an attachment (ERROR
    {"path":"/post/upload","error":"You do not have enough privileges for this action."}), i'll add the contents of it here:

    SOFTWARE INFORMATION
    Package: at.bitfire.davdroid
    Version: 1.5.0.1-gplay (142) Mon Mar 27 11:46:27 GMT+02:00 2017
    Installed from: com.android.vending
    JB Workaround installed: no

    CONFIGURATION
    Power saving disabled: yes
    android.permission.READ_CONTACTS permission: granted
    android.permission.WRITE_CONTACTS permission: granted
    android.permission.READ_CALENDAR permission: granted
    android.permission.WRITE_CALENDAR permission: granted
    org.dmfs.permission.READ_TASKS permission: granted
    org.dmfs.permission.WRITE_TASKS permission: granted
    System-wide synchronization: automatically
    Account: <anonymized-account-email>
    Address book sync. interval: 240 min
    Calendar sync. interval: 1440 min
    OpenTasks sync. interval: 240 min
    WiFi only: false
    [CardDAV] Contact group method: CATEGORIES
    [CalDAV] Time range (past days): 90
    Manage calendar colors: true
    Address book account: Contacts (<anonymized-account-email> 5Q)
    Main account: Account {name=<anonymized-account-email>, type=bitfire.at.davdroid}
    URL: http://localhost:8081/remote.php/dav/addressbooks/users/michi/contacts/
    Sync automatically: true

    SQLITE DUMP
    android_metadata
    | locale |
    | en_US |

    settings
    | setting | value |
    | distrustSystemCerts | 1 |

    services
    | _id | accountName | service | principal |
    | 1 | <anonymized-account-email> | carddav | http://localhost:8081/remote.php/dav/principals/users/michi/ |
    | 2 | <anonymized-account-email> | caldav | http://localhost:8081/remote.php/dav/principals/users/michi/ |

    sqlite_sequence
    | name | seq |
    | services | 2 |
    | homesets | 5 |
    | collections | 8 |

    homesets
    | _id | serviceID | url |
    | 4 | 1 | http://localhost:8081/remote.php/dav/addressbooks/users/michi/ |
    | 5 | 2 | http://localhost:8081/remote.php/dav/calendars/michi/ |

    collections
    | _id | serviceID | url | readOnly | displayName | description | color | timezone | supportsVEVENT | supportsVTODO | sync |
    | 5 | 1 | http://localhost:8081/remote.php/dav/addressbooks/users/michi/contacts/ | 0 | Contacts | <null> | <null> | <null> | <null> | <null> | 1 |
    | 6 | 2 | http://localhost:8081/remote.php/dav/calendars/michi/contact_birthdays/ | 1 | Contact birthdays | <null> | -54 | <null> | 1 | 1 | 1 |
    | 7 | 2 | http://localhost:8081/remote.php/dav/calendars/michi/personal/ | 0 | JKU | <null> | <null> | <null> | 1 | 1 | 1 |
    | 8 | 2 | http://localhost:8081/remote.php/dav/calendars/michi/ab87f639-1969-4ce4-814a-1abf5565eb2f/ | 0 | Private | <null> | -37632 | BEGIN:VCALENDAR<CR><LF>BEGIN:VTIMEZONE<CR><LF>TZID:Europe/Vienna<CR><LF>TZURL:http://tzurl.org/zoneinfo/Europe/Vienna<CR><LF>X-LIC-LOCATION:Europe/Vienna<CR><LF>BEGIN:DAYLIGHT<CR><LF>TZOFFSETFROM:+0100<CR><LF>TZOFFSETTO:+0200<CR><LF>TZNAME:CEST<CR><LF>DTSTART:19810329T020000<CR><LF>RRULE:FREQ=YEARLY;BYMONTH=3;BYDAY=-1SU<CR><LF>END:DAYLIGHT<CR><LF>BEGIN:STANDARD<CR><LF>TZOFFSETFROM:+0200<CR><LF>TZOFFSETTO:+0100<CR><LF>TZNAME:CET<CR><LF>DTSTART:19961027T030000<CR><LF>RRULE:FREQ=YEARLY;BYMONTH=10;BYDAY=-1SU<CR><LF>END:STANDARD<CR><LF>BEGIN:STANDARD<CR><LF>TZOFFSETFROM:+010521<CR><LF>TZOFFSETTO:+0100<CR><LF>TZNAME:CET<CR><LF>DTSTART:18930401T000000<CR><LF>RDATE:18930401T000000<CR><LF>END:STANDARD<CR><LF>BEGIN:DAYLIGHT<CR><LF>TZOFFSETFROM:+0100<CR><LF>TZOFFSETTO:+0200<CR><LF>TZNAME:CEST<CR><LF>DTSTART:19160501T000000<CR><LF>RDATE:19160501T000000<CR><LF>RDATE:19170416T030000<CR><LF>RDATE:19180415T030000<CR><LF>RDATE:19200405T030000<CR><LF>RDATE:19400401T030000<CR><LF>RDATE:19430329T030000<CR><LF>RDATE:19440403T030000<CR><LF>RDATE:19450402T030000<CR><LF>RDATE:19460414T030000<CR><LF>RDATE:19470406T030000<CR><LF>RDATE:19480418T030000<CR><LF>RDATE:19800406T000000<CR><LF>END:DAYLIGHT<CR><LF>BEGIN:STANDARD<CR><LF>TZOFFSETFROM:+0200<CR><LF>TZOFFSETTO:+0100<CR><LF>TZNAME:CET<CR><LF>DTSTART:19161001T010000<CR><LF>RDATE:19161001T010000<CR><LF>RDATE:19170917T030000<CR><LF>RDATE:19180916T030000<CR><LF>RDATE:19200913T030000<CR><LF>RDATE:19421102T030000<CR><LF>RDATE:19431004T030000<CR><LF>RDATE:19441002T030000<CR><LF>RDATE:19450412T030000<CR><LF>RDATE:19461006T030000<CR><LF>RDATE:19471005T030000<CR><LF>RDATE:19481003T030000<CR><LF>RDATE:19800928T000000<CR><LF>RDATE:19810927T030000<CR><LF>RDATE:19820926T030000<CR><LF>RDATE:19830925T030000<CR><LF>RDATE:19840930T030000<CR><LF>RDATE:19850929T030000<CR><LF>RDATE:19860928T030000<CR><LF>RDATE:19870927T030000<CR><LF>RDATE:19880925T030000<CR><LF>RDATE:19890924T030000<CR><LF>RDATE:19900930T030000<CR><LF>RDATE:19910929T030000<CR><LF>RDATE:19920927T030000<CR><LF>RDATE:19930926T030000<CR><LF>RDATE:19940925T030000<CR><LF>RDATE:19950924T030000<CR><LF>END:STANDARD<CR><LF>BEGIN:STANDARD<CR><LF>TZOFFSETFROM:+0100<CR><LF>TZOFFSETTO:+0100<CR><LF>TZNAME:CET<CR><LF>DTSTART:19200101T000000<CR><LF>RDATE:19200101T000000<CR><LF>RDATE:19460101T000000<CR><LF>RDATE:19810101T000000<CR><LF>END:STANDARD<CR><LF>END:VTIMEZONE<CR><LF>END:VCALENDAR<CR><LF> | 1 | 1 | 1 |

    SYSTEM INFORMATION
    Android version: 6.0.1 (cm_klte-userdebug 6.0.1 MOB30Z dd924bc6e0 test-keys)
    Device: Samsung SM-G900F (klte)


  • developer

    Did you try to force-close Contacts and open it again? Or to reboot the system? Is the display filter in Contacts app set to "all contacts"? The address book has changed with the update, maybe it's only a filter/display problem.



  • Thanks for the quick response. Yes I've tried to force-close the contacts app and also tried to reboot my phone. Unfortunately, the problem is still there. It seems that the contacts are missing in the contacts provider - i analysed the sqlite databases in /data/data/com.android.providers/databases/ again, but could not find any contact there (maybe this is a wrong assumption?)

    0_1490826015741_screenshots-001.jpg 0_1490826116612_Screenshot_20170330-001716.jpg


  • developer

    The database used in recent versions of Contacts Provider is located at /data/data/com.android.providers.contacts/databases/contacts2.db. If they're not there, they're probably gone.



  • Ups, there was the .contacts-part in the path missing in my last post :thumbsup: contacts2.db is exactly the file i've checked.
    I think it's a bit difficult to diagnose further (without a lot of effort)...

    If nobody else experiences the same problem, it might be something else as DavDroid is used by quite a lot of people. If i come across further findings i'll post them here - otherwise i'll create backups more often ;-)



  • I got the same issue right after I updated DAVdroid from Play Store. I haven't tried to restore my contacts yet. I'll try, the next opportunity I get.



  • Same problem with 1.5-ose from fdroid.org. I have calendars; no contacts.


  • admin

    @pbryan @shieldwed @MichiBarth Can you try to open the DAVdroid account, unselect all contacts, then refresh the contacts list and select the desired address books again? Otherwise you can you also try to reinstall DAVdroid.



  • Same issue here, but reinstalling and reconfiguring DAVDroid resolved it. It was strictly a sync failure, not a wipe; my server still had all my contacts. The fact that it was scary is a reminder that my server is overdue for a backup :)


  • developer

    The migration from DAVdroid 1.4 to 1.5 is very complicated and risky and there might be cases where it doesn't work as expected. In this case, just re-install DAVdroid / add the account again.

    Unfortunately, we didn't receive a single beta test feedback for 1.5, so we could only do our own test cases (where everything worked).



  • Same problem with the 1.5-ose. I've tried to remove the account and add it again, but didn't work. Downgraded to 1.4 and works fine


  • developer

    @enrico Did you try uninstalling DAVdroid and install it again?



  • @rfc2822 no, because I didn't read your post. I'll try to update and reinstall the app.



  • It doesn't work. 1.5 don't syncs my contacts with my google account. I've completely removed the app and reinstalled it. It still doesn't work.

    All fine with 1.4.

    Ps. I'm really sorry to see that I'm a bit Off Topic because I'm using a MEIZU (Flyme OS) without Google Services. This thread seems for the CyanogenMod


  • developer

    @enrico I see.



  • @devvv4ever I installed it from a fresh install of LineageOS when I had the problem. Uninstalled and reinstalled. Same problem. I notice when I tell it to manually sync, the horizontal status crawler under the collection only flashes briefly before disappearing.


  • developer

    @pbryan said in It seem that there are all contacts gone after update to 1.5.0.1-gplay:

    @devvv4ever I installed it from a fresh install of LineageOS when I had the problem. Uninstalled and reinstalled. Same problem. I notice when I tell it to manually sync, the horizontal status crawler under the collection only flashes briefly before disappearing.

    That's normal behavior on Android 6/7, which waits some time until the address book sync requests are processed. How long did you wait?

    You can also have a look in Android settings / Accounts / DAVdroid address book / and then the respective address book. There should be a Contacts synchronization for each account, and you can see when the last sync of this address book was initiated. If there's a non-rotating arrow symbol, a sync is still pending.



  • @rfc2822 I'm still waiting. :-)


  • developer

    @pbryan Can you please post a screenshot of the respective account in Android settings / Accounts / DAVdroid address book accounts / <address book>? Is there "Contacts", and is it enabled, and is there an arrow, and is it rotating?



  • Watching the server, I see no HTTPS requests on it when I tell it to synchronize. I did see it perform PROPFIND discovery when I added the calendar to DAVdroid.


Log in to reply
 

Looks like your connection to Bitfire App Forums was lost, please wait while we try to reconnect.