Groups/Categories not synced anymore

  • Hi!

    I’m using the latest DAVdroid with my Nextcloud server (ver. 11.0.1) to sync Contacts/Calendar to my other devices (Outlook, Android, Linux). Recently I found out that Groups/Categories are not synced anymore to my Android phone. I could not found the solution for this issue in the forums or anywhere else.

    Here’s what I did:

    1. Configure the DAVdroid on the phone as per instructions regarding groups
    2. Create a new contact on the NC WEB GUI and add it to a new group
    3. Run the sync on the phone manually
    4. Check the contacts on the phone and there is no Category field

    Here are the links for my debug and log files:

    The same contact is synced OK on my other clients on the PC (with the Category visible).

    Than I rememberd that I tried this once before with an earlier version of DAVdroid and this was not a problem. So I went and removed it and installed version 1.3.8 and tried this all over again. And indeed I found out that the Category was synced and visible on my phone. (Sorry I don’t have any logs as now I’m back to version

    Could you please check if this is a known problem or am I doing something wrong?

  • developer

    I can reproduce this problem and it seems to be a DAVdroid bug, caused by the grotesque Android 7 hash code workaround which badly influcences the whole sync logic.

  • developer

    Should be fixed with davdroid/6dd31063. I have sent an APK for testing, please tell us whether it works.

  • I would like to confirm that with the sent version of DAVdroid this particular issue is no longer present: the groups get synced from NC to Android.

    But I did found one problem - I’m not sure if it is DAVdroid related. Namely deleting one of the groups on my phone is NOT synced back to NC server: I can still see the group and all of its memebers on the NC web GUI (no matter how many times do I manually sync from DAVdroid). The only way to ger rid of the group is to delete all of the members from it and then sync - the group is gone from the NC server as well.
    Could this be the problem with DAVdroid or is it some strange Android behaviour?

  • developer

    @avalx Please try DAVdroid, we have fixed some problems of these kind. Please note that the already complicated group support with two methods (CATEGORIES + VCard 4) plus the ugly, complicated Android 7 workaround is really a mess. We have never expected to have such critical workarounds, so in Android 7, unexpected behavior might occur in some cases. Also, group support doesn’t work correctly on all devices. For instance, on our Samsung Galaxy Tab 10.1 with Android 4.4, group changes are sometimes not marked as DIRTY/DELETED (which is not a DAVdroid problem).

  • OK, I’ll try that version although this functionality is not really important for me.

    Anyway, thanks for the quick fix! 👍

Similar topics

  • 4
  • 31
  • 14