Can't see "Network Tablet" in xinput list



  • Firstly, thank you for sharing such a cool app. Secondly, can you help me get it to work?

    I have a server install of linux (Linux UbuntuServer 3.5.0-47-generic #71~precise1-Ubuntu SMP Wed Feb 19 22:02:52 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux) that i added xorg and fluxbox to. I am able to run opengl apps (blender, gimp, krita, etc) in turbovnc so I think that X is fairly well configured and functioning.

    I have downloaded the linux part the equation and also compiled it but can't seem to get the Network Tablet to show up in xinput or anywhere else. I have to run ./networktablet as root. The tablet app connects and I can see the x,y,pressure list in the terminal I started the app from.

    .x: 16015, y: 16728, pressure: 3212
    .x: 14006, y: 19248, pressure: 3340
    .x: 14403, y: 19633, pressure: 3405
    .x: 14984, y: 19935, pressure: 3405
    .x: 15791, y: 20237, pressure: 3405
    .x: 16669, y: 20370, pressure: 3405
    .x: 17659, y: 20521, pressure: 3405
    

    xorg-evdev was already installed.

    When I look at the end of Xorg.0.log this is what I see:

    [  2714.420] (II) config/udev: Adding input device Network Tablet (/dev/input/event8)
    [  2714.420] (**) Network Tablet: Applying InputClass "evdev touchscreen catchall"
    [  2714.420] (II) Using input driver 'evdev' for 'Network Tablet'
    [  2714.420] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
    [  2714.420] (**) Network Tablet: always reports core events
    [  2714.420] (**) evdev: Network Tablet: Device: "/dev/input/event8"
    [  2714.420] (--) evdev: Network Tablet: Vendor 0x1 Product 0x1
    [  2714.420] (--) evdev: Network Tablet: Found absolute axes
    [  2714.420] (--) evdev: Network Tablet: Found x and y absolute axes
    [  2714.420] (--) evdev: Network Tablet: Found absolute touchscreen
    [  2714.420] (II) evdev: Network Tablet: Configuring as touchscreen
    [  2714.420] (**) evdev: Network Tablet: YAxisMapping: buttons 4 and 5
    [  2714.420] (**) evdev: Network Tablet: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout:$
    [  2714.420] (**) Option "config_info" "udev:/sys/devices/virtual/input/input12/event8"
    [  2714.420] (II) XINPUT: Adding extended input device "Network Tablet" (type: TOUCHSCREEN, id 9)
    [  2714.420] (II) evdev: Network Tablet: initialized for absolute axes.
    [  2714.420] (**) Network Tablet: (accel) keeping acceleration scheme 1
    [  2714.420] (**) Network Tablet: (accel) acceleration profile 0
    [  2714.420] (**) Network Tablet: (accel) acceleration factor: 2.000
    [  2714.420] (**) Network Tablet: (accel) acceleration threshold: 4
    [  2714.421] (II) config/udev: Adding input device Network Tablet (/dev/input/mouse0)
    [  2714.421] (II) No input driver specified, ignoring this device.
    [  2714.421] (II) This device may have been added with another device file.
    

    This is how the log file looks even with the x.y.pressure whizzing down the other xterm window. I have tried using the /dev/input/mouse0 and the /dev/input/event8 in gimp's "Linux Input" controller but it doesn't work.

    Any insight you could give would be greatly appreciated.

    Squash



  • Never mind, I was up too late. The input device needs to be on the local machine while using vnc....


Log in to reply
 

Looks like your connection to Bitfire App Forums was lost, please wait while we try to reconnect.