DAVdroid doesn't see “main” calendar from radicale server anymore

  • Hi,

    I have an issue with latest DAVdroid but I’m a bit unsure when it started. I just switched phone and thus did a new DAVdroid install on the new one, doing the exact same configuration. The new install didn’t show my main calendar, it displayed various .ics I’ve created for tasks and todos (mainly from Evolution). It also shows a “Reminders” item with only the clock icon and not the calendar one.

    I’ve tried to refresh the calendars multiple time but it didn’t show my calendar. I’ve then tried to refresh the calendar list on my old phone, and then my main calendar actually disappeared…

    I’ve tried to look at the logs, and it seems that my main calendar has a Displayname of Reminders (not sure where it comes from, from Radicale, from DAVdroid or from some calendar setup), and it only has VTODO support and not VEVENT:

              <C:calendar />
              <collection />
                <all />
                <read />
                <write />
                <write-properties />
                <write-content />
              <C:comp name="VTODO" />
          <status>HTTP/1.1 200 OK</status>
            <CR:addressbook-description />
            <CR:supported-address-data />
            <C:calendar-description />
          <status>HTTP/1.1 404 Not Found</status>

    I’m not sure what sets the VTODO/VEVENT tags, but the same setup was working just fine when I setup DAVdroid on the old phone. Maybe something is wrong on my configuration or maybe something changed in DAVdroid, I can’t say, so any help appreciated.

  • Ok so it seems that the issue was indeed in the calendar properties. I edited manually the calendar.ics.props file on the radicale server (not sure how one’s supposed to do that), which indeed had:

    “C:supported-calendar-component-set”: “VTODO”, “D:displayname”: “Reminders”

    I think it was made like this when I added the calendar to an iPhone. So in the end it doesn’t look like a DAVdroid issue, sorry for bothering.

  • admin

    Thanks for the update and great that you found the problem!

Similar topics