[PROBLEM] DavDroid (on Android 5.0) + Nextcloud 10.0.1 (on Ubuntu 16.04) on my own vserver is not working

  • Heyy guys,

    I installed nextcloud a few hours ago on my own vserver, which I rented by a german hoster.

    First of all I have to say, that english is not my native language and I know not too much about linux.

    These are my system informations:

    2 vCores
    2 GB RAM
    300 GB SSD
    Linux: Ubuntu 16.04 .1 LTS
    Nextcloud: 10.0.1
    Apache: 2.4.18

    Android: 5.0
    Device: ASUS ZenFone2

    This problem occurs when I try to connect to my nextcloud server from my Android device.
    I enter my domain, user and password and get the following message.

    DavDroid Error Log

    All the other stuff on my nextcloud server runs fine.

    If there are any needed informations I post it.


  • developer

    Hello, as you can see in the logs, that’s the problem reported by Nextcloud:

    <d:error xmlns:d="DAV:" xmlns:s="http://sabredav.org/ns">
      <s:message>Username or password was incorrect, Username or password was incorrect</s:message>

  • @rfc2822 thanks for your fast answer!

    Like I said before, my username and password are correct.
    This can’t be the problem … =/

    Do you have any other ideas?

    I forgot to say, that I use SSL and force HTTPS.
    And my hoster provided an SSL-certificate but my browser (Firefox) says it’s not trustworthy.


  • developer

    It must be the problem, but the error message may not be exact. Do you have special (non-ISO-8859-1) characters in your credentials? Do you use LDAP authentication? Can you access the WebDAV URL in your browser or curl etc.?

  • @rfc2822
    I checked all my characters in my password for ISO-8859-1 characters and all of them are in this list.
    -> No, I don’t use non-ISO-8859-1 characters.

    I think (I’m not 100% sure) that I don’t use ldap authentication.
    If you show me how I can test it, I will do it 😃

    I can’t directly access webdav in my browser. When I go to “https:MYDOMAIN/CLOUDFOLDER/remote.php/dav/” I get the following message:
    “This is the WebDAV interface. It can only be accessed by WebDAV clients such as the ownCloud desktop sync client.”
    This happens when I’m logged into Nextcloud on my browser (in another TAB), but if I’m NOT logged into nextcloud, the site shown above forces myself to login. After I entered my username and password the site loads a while and then asks again for my login details. This happens as long as I repeatedly enter my username and password. If I abort the login I get the message “Unauthorized” with some technical details.

    And I don’t know how to use curl. I installed it, but I can’t really work with it, because I don’t understand how it works.
    If you show me a command I how I can use it, I will test it!

    I also can create a testuser for you and send you the password if you want.

    I tried it with a much weaker password and - what a wonder - it seems to work fine…
    Thanks so much for your help!

  • developer

    You could have tried curl -vX OPTIONS -u user:password https://MYDOMAIN/CLOUDFOLDER/remote.php/dav/. But if it works now, then I guess it’s not necessary anymore.

  • I found the problem with my issue!
    For everyone with the same problem as me, don’t use umlauts like “ö”, “ü” or “ä”.

    That’s the magic …

    Thanks again @rfc2822 !


  • developer

    @.point. The problem is that Nextcloud expects the password as UTF-8, whereas okhttp sends it as ISO-8859-1, which is – in my opinion – correct. The only real solution would be to implement RFC 7617 on both sides. Until then, I can only recommend to refrain from using special characters (= non-US-ASCII) in passwords.

  • developer

Similar topics