Davdroid + Nextcloud (on LiteSpeed) not working

  • Hi, issues with this combination.

    Error is ‘Couldn’t find CalDav or CardDav service.’

    My Nextcloud is in a directory i.e website.com/nextcloud/

    In the root public directory I have added

    Redirect 301 /.well-known/carddav /cloud/remote.php/dav/
    Redirect 301 /.well-known/caldav /cloud/remote.php/dav/

    I do not understand why it is not working. I tried disabling GZip, the other solution on this forum. No dice.

    Logs are here: http://pastebin.com/dcdjR4U6

  • developer

    @gugulethu Hello, seems like your LiteSpeed server advertises HTTP/2 support, but doesn’t provide it. Did you activate HTTP/2 in LiteSpeed? Does it work with other clients (browsers, etc)?

  • Hi, I got my web host to disable HTTP/2.

    Still the same issues.
    I also tried just using the direct URL: https://site/cloud/remote.php/dav

    When i put this URL into my browser it returns a login box as it should, but apparently davdroid does not even get there.

    The main errors I’m picking up in the logs is: No principal found at user-given URL, trying to discover AND 505 HTTP version not supported

    Log is here http://pastebin.com/EtmBvMLk

  • developer


    68.2016-10-09 12:20:31 0 [HttpClient$1] --> OPTIONS https://gugulet.hu/cloud/remote.php/dav/principals/users/mlungisi/ http/1.1
    69.2016-10-09 12:20:31 0 [HttpClient$1] --> END OPTIONS
    70.2016-10-09 12:20:32 0 [HttpClient$1] <-- 505 HTTP Version not supported https://gugulet.hu/cloud/remote.php/dav/principals/users/mlungisi/ (433ms)
    80.2016-10-09 12:20:32 0 [HttpClient$1] <!DOCTYPE html>
    81.<html style="height:100%">
    82.<head><title> 505 HTTP Version not supported
    <p>Only HTTP/1.0, HTTP/1.1 is supported.</p>

    As you can see, the request is sent as HTTP/1.1 request, but the server says it only supports HTTP/1.0 and HTTP/1.1, which doesn’t make any sense. Because the request looks fine for me, this really looks like a server problem.

    Can you provide a test account so that we can reproduce the Problem?

  • Hi, you can use the following details

    Username: test
    PW: testaccount01
    URL: https://gugulet.hu (or the complete https://gugulet.hu/cloud/remote.php/dav)

    I’m also talking to my host about this HTTP1.0/1.1 issue.

    Thanks for your help

  • developer

    @gugulethu Thanks for the test account. It’s a server problem, you can reproduce it with curl:

    $ curl -u test:testaccount01 -vX OPTIONS https://gugulet.hu/cloud/remote.php/dav
    > OPTIONS /cloud/remote.php/dav HTTP/1.1
    < HTTP/1.1 505 HTTP Version not supported

    Maybe the server blocks OPTIONS requests?

  • Thank you so much for your help. That was the issue. Apparently Litespeed v1.5.8 introduced this bug. Updated to 1.5.9 and everything is going swimmingly. You might want to put up a note for any other users who have this issue.

    Thank you again, you support is wonderful.

Similar topics