• Hi,
    I posted an issue on nextcloud support website about a problem using davdroid with nextcloud 10. There was a similar issue already solved in the past as mentioned in my post.
    I don’t know where this post should go : nextcloud and/or davdroid. Then I reference this post here : https://help.nextcloud.com/t/davdroid-no-longer-works-with-nc-again/3683

  • developer


    2016-09-28 16:48:36 2 [HttpClient$1] <-- 200 OK http://owncloud.myDomain.com/remote.php/dav/principals/users/myUser/ (644ms)
    2016-09-28 16:48:36 2 [ui.setup.DavResourceFinder] Well-known URL detection failed
    EXCEPTION java.io.EOFException
    at okio.RealBufferedSource.require(RealBufferedSource.java:59)
    at okio.GzipSource.consumeHeader(GzipSource.java:114)
    at okio.GzipSource.read(GzipSource.java:73)
    at okio.RealBufferedSource.request(RealBufferedSource.java:66)
    at okhttp3.logging.HttpLoggingInterceptor.intercept(HttpLoggingInterceptor.java:238)
    at okhttp3.internal.http.RealInterceptorChain.proceed(RealInterceptorChain.java:92)

    Seems like there is a problem on network/HTTP level. Do you use HTTP/2?

    If not, I guess there’s some problem in your Apache configuration. Do you use a proxy? Did you try another device? Did you try another kind of network access (WiFi/mobile data)? Is your WiFi connection stable? Can you access the NextCloud Web interface from your mobile device?

    What about the solution posted in the Nextcloud forum? Did you try it?

    Since you’re using plaintext HTTP, you might try capturing the network traffic on the server (for instance, with tcpdump) and see whether the HTTP messages are sent correctly.

  • The fix from Nextcloud changed the error (it is no more a 503 one) but there is still an error : http://cxg.de/_b5eca6.htm

    Other answers:
    I don’t think I use http/2 since I am hosted on OVH shared host.
    I don’t use a proxy.
    I tried 3 devices:

    • my android 5.1 mobile phone. It does not work (davdroid 1.3.1-ose as well)

    • my wife’s android 4 phone. It does not work (davdroid 1.3.1-ose as well)

    • my computer with owncloud client (wabdav), lightning (caldav) and sogo connector (carddav). it all works well.

    I tried wifi and 4G access : same result
    My wifi connection is really stable. I use it everyday with professional usage.
    I have no problem at all to access the web interface of my nextcloud from any devices including mobile device.

    If needed for the new error message, I’ll try to capture network traffic.

  • Hi!

    Any hint on my dav droid log http://cxg.de/_b5eca6.htm
    It seems an exception appears on “[ui.setup.DavResourceFinder] PROPFIND/OPTIONS on user-given URL failed”.
    Do you know what it means? And how I could solve that?


  • admin

    Did you try with DAVdroid

  • developer

    @philippeVerney Or can you maybe provide a test account so that we can have a look? play@bitfire.at (OpenPGP key)

  • @devvv4ever Actually I use F-Droid on my phone and 1.3.2 is not built there yet. And I don’t feel like buidling it. I might give a try with the play store version.

    @rfc2822 I created a test account, I am going to send it to you by email.

    FYI, I’ve installed “CalDav Sync Adapter” app on my android phone and it works fine with my server. I also installed “CardDAV-Sync free” app but it does not work neither.

  • developer

    @philippeVerney It’s a server problem.

    Which Web server do you use? Does the Web server provide additional gzip compression? The problem is that the server response for OPTIONS says there’s a 0-byte gzip-compressed body (reproduced by using curl):

    $ curl --compressed -nvX OPTIONS -u **** https://yourserver/remote.php/dav/principals/users/davdroid/
    > OPTIONS /remote.php/dav/principals/users/davdroid/ HTTP/1.1
    > Accept-Encoding: deflate, gzip
    < HTTP/1.1 200 OK
    < Content-Type: text/html; charset=UTF-8
    < Content-Length: 0
    < Content-Encoding: gzip

    A response body which is gzip-ed can’t be 0 bytes, see also https://github.com/square/okhttp/issues/1550 (and try zcat /dev/null; while RFC 1952 just speaks about a “series of members”, not mentioning whether “no member” already is a “series”, but I guess not).

    Because our Nextcloud test installation doesn’t show this behavior (sending Content-Encoding: gzip together with Content-Length: 0), I assume that your Web server may provide faulty gzip compression. If you can turn it off, please try that.

    Please contact your server admin and provide this thread as reference.

  • Thanks a lot for your replies!

    My web server is an apache but I don’t own it. It is a web hosting provided by OVH : https://www.ovh.co.uk/web-hosting/web-hosting-personal.xml
    I don’t think I changed anything with its default configuration so I am surprised to be the only one to report this. I am going to check if I can change the configuration or I will contact OVH directly (which is going to take a lot of time since I have a really low level web hosting)
    The only strange point to me remains “Why an upgrade of owncloud 9.0.4 to nextcloud 10.0 and/or an upgrade to davDroid 1.3.1-ose has changed the behaviour (it worked before), it has nothing to do with my server configuration.”. It might be a coincidence with a change from OVH on the server side.
    Again thanks a lot, now I am going to find out what to change on my web server.

    And, because my web server is at OVH and becasue it is a low level one, I don’t think I’ll be able to do “zcat /dev/null” on it.

  • I just found out how to disable gzip compression which is by default enabled on ovh web hosting.
    We have simply to add the 3 following lines to the .htaccess file which is at the root of the nextcloud directory:
    <IfModule mod_deflate.c>
    SetEnv no-gzip 1

    And, as davDroid indicated, it works perfectly once this gzip compression is disabled.
    Again thank you so much for all your replies!

    PS : I don’t know how to mark this topic to “solved” but it is solved.

Similar topics