Older calendar entries not synced from server to phone.

  • When I still used owncloud 7, calendar sync with Davdroid worked fine. Then came owncloud 8, and davdroid couldn’t sync old calendar entries (made during owncloud 7) from server to phone. But even then another F-Droid app CalDAV Sync Adapter worked normally! Davdroid doesn’t sync even entries made in april 2016 from server to phone.

    I always have the latest Davdroid installed from F-DROID.

    Now I’ve migrated to latest nextcloud 10, and I still cannot sync those calendar entries made in 2015 or spring 2016 from the server to my android phone. However, I can create a new entry and sync it to the server and vice versa. But If I go to for example april 2016 and try to create a new entry, it stays there for a moment and then disappears.

    CalDAV Sync Adapter how ever works all the time normally.

    Steps to reproduce:

    1. Fresh new install of custom ROM on Oneplus One (all data formatted i.e. clean install)
    2. install davdroid
    3. setup davroid with nextcloud
    4. select contacts and calendar for sync
    5. contacts sync always fine from remote nextcloud instance to android phone
    6. calendar doesn’t show old entries, but I can start creating new entries, which seems to sync fine (except if I choose to create and an entry to history)

    All the permissions are fine: Davdroid, Calendar, Contacts, and Calendar storage has correct permissions.

  • developer


    Davdroid doesn’t sync even entries made in april 2016 from server to phone.

    What did you set in the respective DAVdroid’s account settings / Time range for past events? By default, it’s 90 days.

  • Well this is embarrassing. Never knew this setting existed. After suffering from this (non)issue for half a year I feel sort of stupid.

    But also happy for the easy solution, than you!

  • developer

    @isojorma We have introduced this feature so that calendar synchronization becomes more scalable. Most people don’t need older events, and they take unnecessary space on the phone and when a full synchronization is done. But of course, you can set the time range and/or disable the feature completely 🙂

Similar topics