Sync with only one Android causes database errors



  • The situation:
    NAS with Baikal 0.4.6 with 3 calendars running.
    Syncing with two different Thunderbird works fine.
    Syncing with Davdoid on Android-Tablet works fine.
    Syncing with Davdroid on smartphone of my wife works fine.

    Syncing 2 of the 3 calendars on my smartphone works fine...
    but the 3rd calendar (for my job) doesn't work correct.

    Since a few day i get always get en database error while syncing the calendar "swo".
    I am syncing this calendar with Outlook (on the job), with Thunderbird and with the Android-Tablet without problems.

    Only on my old (Samsung S3 mini with cynogenmod) and on my new Smartphone (Moto G3 wit Android 6) i get this error.
    Although all events are displayed as it seems, but i am not sure.
    Anyway i am not sure wether all events are synced complete.

    I have already tried to clean the database of all entries and imported from ics-files on the Moto G3. Still the same error on syncing.
    Any hint 4 me ?

    Debug
    Info


  • developer

    There seem to be problems with the exceptions of the recurring event /html/dav.php/calendars/steve/swo/8175b277-a5f0-4c4b-95aa-636632459a1b.ics. Can you please post it or send to play@bitfire.at (PGP)?

    Does sychronizing other events work on those devices?



  • Yes, as it seems all other other events will be synced...

    Unfortunately all events have another uri (the long string at the end) in my database since i have cleaned this calendar and build it up again from an complete ics-file.

    So the event you are asking for has an new uri.
    I have to repeat the log-file to find out the new uri causing the problem.
    How do i recognise the event causing problems in the log-file ?


  • developer

    The last "Adding to local calendar" entry before the error message:

    2016-09-03 01:17:18 1 [syncadapter.CalendarSyncManager] Adding 8175b277-a5f0-4c4b-95aa-636632459a1b.ics to local calendar
    [ … ]
    2016-09-03 01:17:18 1 [ical4android.BatchOperation] Committing 91 operations …
    2016-09-03 01:17:18 1 [ical4android.BatchOperation] Running operations 0 to 90
    2016-09-03 01:17:19 1 [syncadapter.SyncManager] Couldn't access local storage
    EXCEPTION at.bitfire.ical4android.CalendarStorageException: Batch operation failed partially (only 0 of 91 operations done)
            at at.bitfire.ical4android.BatchOperation.runBatch(BatchOperation.java:90)
            at at.bitfire.ical4android.BatchOperation.commit(BatchOperation.java:58)
            at at.bitfire.ical4android.AndroidEvent.add(AndroidEvent.java:357)
            at at.bitfire.davdroid.syncadapter.CalendarSyncManager.processVEvent(CalendarSyncManager.java:228)
            at at.bitfire.davdroid.syncadapter.CalendarSyncManager.downloadRemote(CalendarSyncManager.java:194)
            at at.bitfire.davdroid.syncadapter.SyncManager.performSync(SyncManager.java:170)
            at at.bitfire.davdroid.syncadapter.CalendarsSyncAdapterService$SyncAdapter.sync(CalendarsSyncAdapterService.java:67)
            at at.bitfire.davdroid.syncadapter.SyncAdapterService$SyncAdapter.onPerformSync(SyncAdapterService.java:87)
            at android.content.AbstractThreadedSyncAdapter$SyncThread.run(AbstractThreadedSyncAdapter.java:272)
    


  • Thanx a lot. Found the suspicious event in my database deleted it and recreated it manually.
    Now it works again ;-)


Log in to reply
 

Looks like your connection to Bitfire App Forums was lost, please wait while we try to reconnect.