• OK - also I got the message of this update. In my case, it did not change the error.

    • Do you have an htaccess entry for ETag. Which entry and where?
    • Do you use ssl-proxy (sslkundenserver.de)?

  • No, don’t have an ETag entry in .htaccess.
    And I don’t use ssl-proxy/sslkundenserver.de… (by the way: what’s that and how does that work?)

  • I’m using an SSL Proxy for connecting to the cloud with a shared SSL connection. So the transfer is more secure. Look at the webspace description at the Providers Homepage. Maybe in my case, the reason for the error is this connection. I asked the provider about this possibility.

  • got feedback from support:

    due to the update to Apache 2.4 hoster configured
    Header unset ETag
    FileETag None

    in the global apache configuration.

    According to the HEADER directive in the apache docs :
    “… The header is modified just after the content handler and output filters are run, allowing outgoing headers to be modified. …”

    So ETag header was generated by OwnCloud/PHP but then removed my mod_header

    Hoster removed “Header unset ETag” from apache config. Now it works.

    @SvenF : already contacted support to set up ssl-proxy for my domain. When it’s done I will test calendar/contact sync via ssl and post feedback here 🙂

  • developer

    Good to know that it now works and what has caused the problem. At least DAVdroid’s error message was correct 🙂

    Do you know why they have removed ETags?

  • They removed the ETag header for “security reasons”.
    Can’t imagine any risk that a ETag can have, but I’m not a security expert… so maybe I just don’t know any better 😉

    @SvenF : tried to set up a separate OwnCloud that I can access via sslkundenserver.de, but for some reasons it always redirects to http://www.mydomain.tld/owncloud instead of staying in https://sslkundenserver.de/www.mydomain.tld/owncloud 😕
    Any hints?

  • @mpausch
    It’s OwnCloud and not DavDroid but I hope it’s OK in this thread…

    I had in my OwnCloud config.php

    This is a part of the config I have used. I’m very interested about your experience. In my case, there are no errors without SSL Proxy, but not possible with the SSL which I want to use for connect.

  • hm, for some reason I’m too dumb to get OC running via sslkundenserver.de
    even with your lines from config.php it kept redirecting to http 😞

    But I made another test. And from the results it seems for me like the proxy on sslkundenserver.de removes the ETag header. So the host that hosts your OC generates the ETag header and delivers it to the ssl-proxy… but then the proxy removes it…

    My test was to retrieve a jpg from my webspace with curl and let the headers write into a simple textfile.

    If you’re on Linux you can reproduce it with curl command. If not you also can reproduce it via ssh access to your webspace:

    retrieve image via https and sslkundenserver.de:
    curl -D headers_https.txt https://www.sslkundenserver.de/www.mydomain.tld/test/image.jpg > image_https.jpg

    retrieve image via http and without sslkundenserver.de:
    curl -D headers_http.txt http://www.mydomain.tld/test/image.jpg > image_http.jpg

    This will save the jpg on the one hand in file image_https.jpg and on the other hand in file image_http.jpg
    In the headers*.txt files you will see the headers that were transferred between client (curl) and server.

    [user@host davdroid-tests]$ ls -la headers_http*
    -rw-r–r-- 1 user user 208 13. Sep 21:12 headers_https.txt
    -rw-r–r-- 1 user user 271 13. Sep 21:11 headers_http.txt

    [user@host davdroid-test]$ grep -i etag headers_http*
    headers_http.txt:ETag: “2741e-53b7f91de8301”
    [user@host davdroid-test]$

    —> so the header only was retrieved via http…

  • So - final message.

    It is fixed also with SSL Proxy.
    They removed “Header unset ETag” from SSL Proxy. Now I use “FileETag -INode +MTime +Size” in htaccess and everything works fine - also with access over SSL-Server.

  • Oh my god!

    I just registered here to say: Thank you so much! I was struggeling with this problem for too long. I contacted bitfire in the past but they kept telling me that this would be an owncloud problem. They told me to wait until Owncloud 9 and all the problems would be gone because they completely reimplemented the calendar/contact stack for OC 9,

    However, after upgrading to OC 9 the problems remained. Just now I realized that it is an apache issue. Why the frack did they turn off ETags by default in 2.4?

    In this thread they say that they didn’t change anything about etags in davdroid, but this is wrong. The support told me that they actually changed the behaviour after version 0.8.something. So I kept using this version before I read the solution on this thread.

    Again, thank you!

Similar topics