CPanel/Horde problem, partly working, no biggy



  • Hi there,

    I have an account with wint.global. They have cPanel 56.0.28 and Horde 5.2.6 , which together offer CalDAV and CardDAv syncing. It works fine, as long as you use the full URL:

    https://ha01s006-cl.org-dns.com:2080/rpc/principals/email@domain.de

    And then username (email@domain.de) and the password.

    But the short URL does not work:

    https://ha01s006-cl.org-dns.com:2080

    This is frustrating, because I set up the subdomains for autoconfig (_caldavs._tcp, etc.). But those can only be set for a domain and a port, not a folder. Thus they currently don't work. If that was to work, I could setup accounts simply using email and password.

    Please note that this might be a bug in cPanel version 56.0.28 or Horde, since I wasn't able to test this with other clients as of yet.

    I am willing to share logfiles of failed attempts or even setup a test account, if someone wants to fix it, but those logfiles contain a lot of personal information.

    If needed, I can also purge all the personal information from the logfile and upload it here, though maybe the information I provided above is sufficient?


  • developer

    This post is deleted!

  • developer

    For Horde, a redirection like this

    RedirectPermanent /.well-known/caldav /horde/rpc/
    

    should be enough. The email@domain.de part should not be necessary in the initial context path. At least it works here with Horde.



  • @rfc2822 said in CPanel/Horde problem, partly working, no biggy:

    For Horde, a redirection like this

    RedirectPermanent /.well-known/caldav /horde/rpc/
    

    should be enough. The email@domain.de part should not be necessary in the initial context path. At least it works here with Horde.

    This can only be changed on the provider's side. I am a customer. This setup runs on their ( ha01s006-cl.org-dns.com ) server.

    Also the records I setup are srv records, not txt records. Either way, I don't really understand why it works with the long URL, but not the short one, since the path /rpc/principals/email@domain.de appears in the error log when I try the short url.

    I may have to clean and publish the full error log.



  • @rfc2822

    0_1469987124884_davdroid-debug1223669242.txt

    I uploaded the full error log.

    And yes, https://ha01s006-cl.org-dns.com:2080/rpc/principals/ will work without the email address added. The path https://ha01s006-cl.org-dns.com:2080, which I have put into srv records for my domain do not work, unfortunately, even though the path /rpc/principals shows up in the error logs. Thus it seems it is referenced somehow. But Davdroid seems unable to interpret it correctly.

    If anyone would like to do further testing, I am willing to set up a test account.

    Since I am a customer and ha01s006-cl.org-dns.com is adminstered by a hosting provider, I am unable to change the Apache configuration. But the hosting provider enables me to edit the dns entries. Thus I can point to the appropirate server and port. But srv entries do not offer a field to enter a path, AFAIK.


  • developer

    @spdgy Did you try adding path=/rpc/principals as a TXT record?



  • It works, thank you.

    The relevant section is here:

    https://tools.ietf.org/html/rfc6764#section-4

    In addition to the SRV records I added path=/rpc/principals/ as txt fields for both _caldavs._tcp and _carddavs._tcp and now I can add accounts on Davdroid just using the email address.

    This thread can be marked as "solved".



  • I just wanted to add that I solved another problem with multiple calendars on my wint.global cPanel Horde accounts.

    When I setup different calendars from multiple accounts, they didn't show up on the Android calendar app. They all had the same color and the same name. I don't know if that was the reason, but I could rename them and give them individual colors in Horde. Then I deleted and recreated the accounts on Davdroid. After that I went into the settings in the calendar app. There I could find the calendars.


Log in to reply
 

Looks like your connection to Bitfire App Forums was lost, please wait while we try to reconnect.