Cannot get service discovery working (Synology and Baikal)



  • I'm trying to get calDAV and cardDAV to work with a single account and the root URL of install on a Synology with Baikal. Therefore I need to configure redirects, but I can't find out what I'm doing wrong.

    I tried to add the following lines to .htaccess:

    Redirect 301 /.well-known/carddav /baikal/carddav
    Redirect 301 /.well-known/caldav /baikal/caldav

    I also tried these lines:

    RedirectMatch 301 ^/.well-known/caldav /cal.php
    RedirectMatch 301 ^/.well-known/carddav /card.php


  • developer



  • Yes, I've read the specific Baikal page. Here's some more info. I've followed these steps:

    1. Already had DAVdroid installed on my device (running Cyanogen 13.1). Now I did try to add a Baikal account configured on my Synology server (Apache). Both devices connected via LAN. Everything is configured successfully, I know this because I was able to add an account in DAVdroid by login in with URL and user name and adding just the the cardDAV or calDAV (http://MYSERVERIP/baikal/card.php, Username/password as configured in Baikal and Pre-emptive authentication unticked)
    2. Next step was trying to use a single account for both cardDAV and calDAV sync. Therefore I need to configure well-known URL's. I added the above lines to the .htcaccess file (located in /web/baikal-app/).
    3. Now I used the root URL to login with DAVdroid (http://MYSERVERIP/), but then DAVdroid could not find a CalDAV or CardDAV service.
    4. I also tried different iterations of the redirect lines (with or without 301, with or without ^ etc.), but nothing worked.

    Here is the logfile.

    I am pretty sure I'm doing the redirects wrong.



  • Which version of baikal are you installing ?

    Have you tried pointing the url to the only /combined http://example.org/baikal/html/dav.php ? Note the Upgrade instructions.



  • No, I'm still on Baikal 0.2.7. I will probably update though, but it's not the cause of the problem at the moment.



  • I am not familiar with the synology webserver, but one last thought, then:

    You are probing http://192.168.1.19/.well-known/carddav. So the .htacces file should be at http://192.168.1.19/.htaccess and probably redirect to /baikal/[card/cal].phpif you not already have additional fancier redirects.

    EDIT: also, you could try opening http://192.168.1.19/.well-known/carddav in a browser and see if you get a 404 error. What is strange though, is that the webserver doesn't tell you it didn't find the url, but sends a 405 Method Not Allowedwhich points to a configuration problem of the webserver.



  • Fixed! I just updated Baikal to 0.4.5. In that version card and cal are combined in a single endpoint. So no need anymore to configure any redirects.

    Thanks anyway!



Looks like your connection to Bitfire App Forums was lost, please wait while we try to reconnect.