last synced date in google account preferences not correct



  • Hi,

    i have following setup:

    • sync with local owncloud server in my local LAN (not reachable from outside)
    • in the account settings, it is set to sync over WiFi only, and restrict (with SSID name) to my own WLAN.

    However, when I am at work all day, and look at preferences -> accounts -> DAVdroid, it shows "last synced" + a time where I definitely have not been at home.

    In my understanding:

    • No sync should have been started (SSID restriction)
    • Even if, the sync cannot be successful (because I am not in my home network, and have no VPN to it)

    Why does the accounts screen tell me, it has synced?

    Regards,
    Arnschi



  • in case you need the debug info:
    http://paste.fedoraproject.org/375508/46524266/


  • developer

    Hello,

    Syncs are scheduled by Android, which also shows the time of the last sync it has started. DAVdroid just checks whether WiFi is active and does nothing when the conditions are not met.

    Works as intended. Fur further information, please have a look at the source code.



  • Thanks for the quick reply, I understand.

    So I understand another downside of this is, that after connecting to my home LAN, the sync is not started immediately.

    Since this is now more or less a feature request, I created a follow up in the feature discussion board.

    https://forums.bitfire.at/topic/1111/add-a-tasker-capability-to-manually-trigger-change-sync-settings

    regards, and thanks for the good work!
    arnschi


Log in to reply
 

Looks like your connection to Bitfire App Forums was lost, please wait while we try to reconnect.