Calendar doesn't synchronise on Huawei Honor 4x


  • developer

    @Bernhard Again, these are only contact sync logs. You can see it in the first line:

    2016-05-29 23:40:00 7 [syncadapter.SyncAdapterService$SyncAdapter] Sync for com.android.contacts has been initiated

    How did you initiate a calendar sync? It seems like it’s just not initiated. You can try to

    1. enable logs
    2. disable calendar sync in Android settings / Accounts / DAVdroid / your account
    3. enable calendar sync again - this should cause a sync (instead of “sync now”)
    4. disable logs, post them


  • I tried synchronising calendar and contacts from within the DAVdroid-app. The calendar is not displayed in the Android-settings, only the address book shows up there. The account is also marked with a red circle and the words “synchronisation error”.



  • @Bernhard If the calendars are not shown, they can of course not be synchronized. However, in this case the red circle would then have to apply to the contacts sync, but those seem to work. Can you post screenshots? It’s just difficult to reproduce this problem here or to get an idea of the actual problem.



  • This is what I tried to describe: http://imgur.com/a/oGR7a



  • @devvv4ever Do you have any idea what might cause this problem?



  • Please help me! 😞 Do you need any further information?



  • Hello Bernhard,

    I’m sorry that we can not help you. Did you try another server or do you have another Android device where everything is working fine?



  • @devvv4ever I tried using another server as well, but the problem was the same. Both times DAVdroid got the calendar name, description and even colour, but the calendar didn’t synchronise. Both servers synchronise with Thunderbird/Lightning.


  • developer

    @Bernhard DAVdroid is not initiating the synchronization. It relies on being called by the Android synchronization framework. According to the debug info, calendar sync is set to 240 min:

    Calendar sync. interval: 240 min

    I don’t know why “Calendar” doesn’t appear in your Android account settings (as seen in your screenshot). Is your calendar provider even enabled? You can have a look at: Android Settings / Apps / All (maybe: “Show system”) / Calendar Storage (com.android.providers.calendar).

    Or maybe DAVdroid is prohibited to access the Calendar provider for some other reason (permissions, privacy guard, …)



  • @rfc2822 Thank you, this was actually the solution! 😄 After enabling the android calendar, synchronisation works as it should.


Log in to reply