[webcal.fi] Unexpected Status Line: HTTP/1.1 200 OK or 304 Not Modified



  • I've been using ICSDroid for some weeks, recently I'm seeing sometimes synchronisation errors like "Unexpected Status Line: HTTP/1.1 200 OK" or "Unexpected Status Line: HTTP/1.1 304 Not Modified". Strange enough the error messages contain a "�" (U+FFFD, REPLACEMENT CHARACTER) at the start of the Status Line.

    IMHO these status lines are fine and should not raise an error, should they?

    I'm running ICSDroid 1.2 on Android 5.1.1 (CyanogenMod)

    Thanks!


  • developer

    If there's a replacement character at the start, they're not OK and can't be parsed Android's HttpsURLConnection which is used by ICSdroid.

    Are you sure that this is not a server problem, i.e. the status lines are really correct? Can you open the Webcal URL with a browser or curl?

    Can you provide an .ics URL so that we can reproduce the problem?



  • I'm using the same URL in Thunderbird (Lightning) without any issues for quite some time, and my first try was opening the URL with a browser and also wget, which works fine.

    One of the .ics URLs in question:

    http://www.webcal.fi/cal.php?id=213&format=ics&wp=53&wf=105&cntr=at&lang=de

    Thanks!


  • developer

    This URL works here… is the problem reproducible?

    "Sometimes errors" doesn't sound good… :/ And also, the browser/wget/curl validation isn't applicable then, because you'd most probably get the version which occurs most times and works.



  • I agree - "sometimes" doesn't sound good, it even isn't good! ;-) The issue is reproducible, unfortunately not at will, but it has hit me several times during the last days. I've already tried to pinpoint the issue by using different WLANs, VPN, different time of day,... but this doesn't seem to have any influence. It seems to boil down to somewhere between the server providing the .ics and ICSDroid. Even getting different calendars from the same server at (almost) the same time yields in different behaviour (see screenshot)

    Let me know if I can provide further details (log files?) to help to solve this issue.

    Thanks!

    0_1461160560683_Screenshot_2016-04-20-12-52-02.png


  • developer

    I have added the calendar and will see if this occurs on my own device.

    Otherwise, my guess is that the server sometimes sends an invalid status line, as said by the error message.



  • Any news on that issue?

    I did some research, could this be a related issue:

    Unexpected status line exception using HttpUrlConnection in android?
    http://www.simosh.com/article/cijgeagh-unexpected-status-line-exception-using-httpurlconnection-in-android.html
    "java.net.ProtocolException: Unexpected status line: ��"


  • developer

    To be honest, I don't know what to do in this case.

    To see what's wrong, we'd need to capture the traffic and see whether the response (status line) is incorrect or whether the Android HTTP client has a bug.

    It's the same problem as you have linked. I will try Connection: close.


  • developer

    Seems like it's really an Android HttpUrlConnection bug and Connection: close does the trick.

    @webdb22 Can you please check again with ICSdroid 1.2.1?


  • developer

    Seems to be solved. Thanks @webdb22!


Log in to reply
 

Looks like your connection to Bitfire App Forums was lost, please wait while we try to reconnect.