Calendar entries disappear after changing the time



  • Hi all,

    I'm using DAVdroid 1.0.2 (but the problem occured with previuos versions as well)
    on Android 6.0 with an LG G3, my server is EGroupware 14.3.007

    In general everything works fine (syncing Calendar and Contacts)
    but changing the time of a calendar entry causes the entry to vanish.

    1. Set up a calendar entry, e. g. 10:00 p.m.
    2. synchronize => everything okay, appears also in EGroupeware
    3. Change time (on phone) to e.g. 10:30 p.m.
    4. synchronize => entry disappears on phone and also in EGroupware

    Would you have a suggestion what is going wrong there?

    Thanks
    Wolfgang


  • developer

    Please provide logs of the whole process:

    1. Create the event, sync
    2. DAVdroid settings / enable "log to external storage"
    3. Update the event, sync
    4. DAVdroid settings / disable "log to external storage"
    5. Upload the logs to fpaste.org or a similar service and provide a link.


  • Hi,

    thanks for the quick answer, here is the link: http://ur1.ca/opzre

    I created the event "Testevent for error" and changed the start time from 10 p.m. to 10:15 p.m.

    Then it disappeared.

    Thanks
    Wolfgang


  • developer

    @realwuffi According to the server logs:

    1. DAVdroid uploads the changed event as expected (PUT http://pausch.org/egroupware14/egroupware/groupdav.php/realwuffi/calendar/2c4a26eb-ed2e-4ab1-b090-299fcbcaee8c.ics http/1.1 with DTSTART;TZID=Europe/Berlin:20160403T221500). The server returns a success status code (204 No Content). So the event should now be on the server.
    2. However, when DAVdroid queries the server, the uploaded file 2c4a26eb-ed2e-4ab1-b090-299fcbcaee8c.ics is not available on the server (as it would have been deleted there).
    3. Thus, DAVdroid deletes the event locally.

    So, I can't see any problems on DAVdroid's side. I guess that:

    1. the server has some delay, so the event may appear again as soon as it's processed by the server, and/or
    2. the server can't process the uploaded event (and returns a success message nevertheless), and/or
    3. the server dismisses the event for some reason.

    Please contact your server vendor (EGroupware) or its community.



  • Thanks,

    I will try at the EGroupware forum.
    But it is a bit strange, as this nevber happens with Thunderbird and SoGo Connector which I also use.

    Cheers
    Wolfgang


  • developer

    @realwuffi said:

    I will try at the EGroupware forum.
    But it is a bit strange, as this nevber happens with Thunderbird and SoGo Connector which I also use.

    The logs are quite clear. Maybe eGroupware doesn't like events generated by DAVdroid for some reason.

    If you find out something, please let us know…



  • Hi there,

    I posted the problem to EGroupware as well, but did not get an answer there.

    I finally chose to swith to another CalDAV-Sync app which seems to work better with EGroupware.

    Thanks anyway.



Looks like your connection to Bitfire App Forums was lost, please wait while we try to reconnect.