OwnCloud calendar not detected from direct URL



  • Hi

    I have a problem to add my Calendars (Owncloud 8.2.3) after the update to DAVdroid 1.X. (in version < 1.X I never had a problem)

    I have try:

    1. delet DAVdroid an reinstall it.

    2. delet DAVdroid and OpenTask, reboot the device, and install it again.

    3. I used https://oc.boerde.de/<myName>/remote.php/caldav/calendars/<username>/uni and
      https://oc.boerde.de/<myName>/remote.php/caldav/

    The syn from my address book (same acc on the same Owncloud) work.
    (I used https://oc.boerde.de/<myName>/remote.php/carddav/addressbooks/<username>/myaddress)

    have you some tips for how i can solve thies problem?

    0_1459410865414_davdroid-debug310496682.txt


  • developer

    I have a problem to add my Calendars (Owncloud 8.2.3) after the update to DAVdroid 1.X. (in version < 1.X I never had a problem)

    Please note that a correlation in time is not necessarily a causal correlation.

    The logs are funny:

    When DAVdroid tries to evaluate the user-given URL for CardDAV capabilities, your server returns 207 (OK):

    2016-03-31 09:31:32 4 [HttpClient$1] --> PROPFIND https://oc.boerde.de/<myName>/remote.php/caldav/calendars/<username>/uni http/1.1
    2016-03-31 09:31:32 4 [HttpClient$1] Content-Type: application/xml; charset=utf-8
    2016-03-31 09:31:32 4 [HttpClient$1] Content-Length: 290
    2016-03-31 09:31:32 4 [HttpClient$1] Depth: 0
    2016-03-31 09:31:32 4 [HttpClient$1] 
    2016-03-31 09:31:32 4 [HttpClient$1] <?xml version='1.0' encoding='UTF-8' ?><propfind xmlns="DAV:" xmlns:CAL="urn:ietf:params:xml:ns:caldav" xmlns:CARD="urn:ietf:params:xml:ns:carddav"><prop><resourcetype /><displayname /><CARD:addressbook-description /><CARD:addressbook-home-set /><current-user-principal /></prop></propfind>
    2016-03-31 09:31:32 4 [HttpClient$1] --> END PROPFIND (290-byte body)
    2016-03-31 09:32:02 4 [HttpClient$1] <-- 207 Multi-Status https://oc.boerde.de/<myName>/remote.php/caldav/calendars/<username>/uni (30776ms)
    

    When the same URL is queried for calendar properties, there's 403 Forbidden:

    2016-03-31 09:32:03 4 [ui.setup.DavResourceFinder] Finding initial caldav service configuration
    2016-03-31 09:32:03 4 [ui.setup.DavResourceFinder] Checking user-given URL: https://oc.boerde.de/<myName>/remote.php/caldav/calendars/<username>/uni
    2016-03-31 09:32:03 4 [HttpClient$1] --> PROPFIND https://oc.boerde.de/<myName>/remote.php/caldav/calendars/<username>/uni http/1.1
    2016-03-31 09:32:03 4 [HttpClient$1] Content-Type: application/xml; charset=utf-8
    2016-03-31 09:32:03 4 [HttpClient$1] Content-Length: 435
    2016-03-31 09:32:03 4 [HttpClient$1] Depth: 0
    2016-03-31 09:32:03 4 [HttpClient$1] 
    2016-03-31 09:32:03 4 [HttpClient$1] <?xml version='1.0' encoding='UTF-8' ?><propfind xmlns="DAV:" xmlns:CAL="urn:ietf:params:xml:ns:caldav" xmlns:CARD="urn:ietf:params:xml:ns:carddav"><prop><resourcetype /><displayname /><n0:calendar-color xmlns:n0="http://apple.com/ns/ical/" /><CAL:calendar-description /><CAL:calendar-timezone /><current-user-privilege-set /><CAL:supported-calendar-component-set /><CAL:calendar-home-set /><current-user-principal /></prop></propfind>
    2016-03-31 09:32:03 4 [HttpClient$1] --> END PROPFIND (435-byte body)
    2016-03-31 09:32:03 4 [HttpClient$1] <-- 403 Forbidden https://oc.boerde.de/<myName>/remote.php/caldav/calendars/<username>/uni (85ms)
    

    If https://oc.boerde.de/<myName>/remote.php/caldav/calendars/<username>/uni is a valid collection which you have access to, your server should not return 403 here. Do you have access and is the calendar app enabled on your server?

    But why do you use the direct calendar URL and not just /remote.php/caldav/ (to allow auto-detection), or, even better, configure well-known URLs and then just use /? Did you try that?



  • @rfc2822 said:

    If https://oc.boerde.de/<myName>/remote.php/caldav/calendars/<username>/uni is a valid collection which you have access to, your server should not return 403 here. Do you have access and is the calendar app enabled on your server?

    I use the same URL (same acc and pw ) in Thunderbrid with Lightning and it works.
    (I have remove some calendar and add it new with no problem)

    But why do you use the direct calendar URL and not just /remote.php/caldav/ (to allow auto-detection), or, even better, configure well-known URLs and then just use /? Did you try that?

    I have try the auto-detection but ther is the same problem.
    I can not configure the well-known url because I have no sftp acc on the owncloud server.

    I check my onecloud config with the "CalDAV Sync Free Beta" from gege. And this app sync correctly so i think that my onecloud work.



  • Hi

    After an update to Owncould 9.0.1 and use from DAVdroid 1.0.7-beta-1 every think working.



Looks like your connection to Bitfire App Forums was lost, please wait while we try to reconnect.