calendars keep being turned on in calendar app (visibility) since update to 1.0x



  • Hi,

    I use quite some calendars and I use business calendar which has a nice bar in the bottom to switch the calendars visible/invisible.

    Since updating davdroid to 1.0 these settings are altered automatically somehow and all calendars are turned on after a couple of seconds/minutes. I updated to 1.02 today to see if it changes anything but it does not. Under 1.0 I tried lots of things like uninstall the whole thing, remove account and readd it and so on. No help. After contacting the business calendar guys I was told that since the problem is also there in the standard Android calendar app it is not a business calendar problem. Since it came with the update I assume it must be davdroid ...

    Any help on this?

    Besides Business Calendar I use a Galaxy S2 with CM13 (27/2/2016 nightly)

    regards


  • developer

    Calendars are currently set to visible at every sync because I didn't have in mind that people want to synchronize invisible calendars.

    Will be changed in next version.



  • wao ... that's great - thanks - good that new versions keep coming up ATM ... ;-)


  • developer

    @daniu What is your use case? Do you just turn the calendar on by occasion to have a look at some events, and then turn it off again?


  • developer

    Should be working in 1.0.4.



  • Thanks :)



  • @rfc822: yes - exactly and yes it is working now.

    e. g. I made a calendar for the sun to see when it is rising and setting so that I can see in advance when there will be natural light in the mornging when I walk the dog ... quite handy, but not cool to have yellow bars on every day ... (well ... OK - this one would not need to get synced every day - but there is still the calendar of my wife, my church, my work and so on ...)



  • Hi,

    just for you to think about: I think there would be one more optimation:
    would it be possible to not sync some calenders all the time? Like I realized that the sunrise and sunset, holdays, school holidays and maybe some others more won't change at all for a long time - so it does not really make sense to ask the server for changes (=sync) them several times a day. However when I turn those calendars off in davdroid they are gone on the device ...

    Get my point?

    regards


  • developer

    @daniu You could set the SYNC_EVENTS flag to 0 in your calendar app: Calendar / Calendars to display / Calendars to sync / Uncheck the calendar.

    However, this depends on your calendar app. DAVdroid's behavior is to add the calendar as soon as it's checked in DAVdroid (with VISIBLE=1 and SYNC_EVENTS=1). But it honors the SYNC_EVENTS flag, so you can manually change it in the calendar app – but beware, you calendar will be checked in DAVdroid, so you may assume that ít's synchronized, but it is not (until you enable it in your Calendar app again).



  • Hi,

    well - cool to know this solution. I got the standard Android Calendar app that provides that setting and assume that I can avoid syncing that way (business calendar does not have that setting).

    However I suggest to regard this as a feature request to have that setting in Davdroid. Pretty sure that there will be surprised people that their calendar is not synced. And I am not sure if I still remember once I add new holidays/sunrise/-set/etc. to my calendar on the server ...

    regards


  • developer

    @daniu We did it intentionally without the "sync" flag in DAVdroid UI, because

    1. for each calendar, there would have to be two "sync" flags: one for the events, one for the tasks,
    2. it makes the whole thing much more complicated and error-prone.

    The "simple" use case is just to check (or uncheck) the calendar in DAVdroid, and it will be added and synchronized (or not). If you're going "advanced", you may change the SYNC_EVENTS in your calendar app, but DAVdroid will only honor it and provide no GUI for that (for above reasons).


Log in to reply
 

Looks like your connection to Bitfire App Forums was lost, please wait while we try to reconnect.