error in Sync phase 0 on cyanogenmod - PrivacyGuard disabled



  • Hi there,

    I set up DAVdroid to synchronisze my contacts to Synology DSM. Setting up the account worked, but now when I try to actually sync I get the following error:
    http://pastebin.com/fxJUAqA5
    saying that it "Couldn't get address book URL" in Synchronization phase: 0.
    Seems like it's an issue purely related to the phone; I am running cyanogenmod on a Samsung Galaxy S2. I have disabled cyanogenmod's privacy guard feature for DAVdroid.

    I'd be happy for any ideas. Thanks.


  • developer

    Sounds like DAVdroid doesn't get access to the address book (Contacts provider). Are you sure you didn't disable the Contacts Provider app? Maybe the Cyanogen privacy guard is still active. Maybe disable it and re-install DAVdroid.



  • There is no "Contacts Provider" app. There is a "Contacts" app and a "Contacts Storage" app. Both are enabled, and privacy guard is disabled.
    (and, as I said, privacy guard is disabled for DAVdroid)


  • admin

    This post is deleted!

  • admin

    Hi,

    we can't reproduce this. We've just tested it with CM 12.1 on a SGS2 and everything works as expected. Which CM are you running?



  • Thanks for your quick responses :)

    Reinstall is always a good guess... It seems that I solved my issue by reinstalling DAVdroid. Now it works.
    What caused the error in the first place? I am not fully sure, but this is my best guess as it is the only thing I can recall having changed:
    I had Privacy Guard set to be enabled by default for all new installed apps (Settings - Security - Privacy Guard).

    • So the first time I installed DAVdroid privacy guard was enabled in the beginning, I then had to disable it manually. (also did a Android restart and cache wipe inbetween) Contact synchronisation still didn't work.
    • The second time I installed DAVdroid privacy guard never got enabled. With this one contact synchronisation worked.

    Maybe some setting from privacy guard is written improperly when it's disabled manually?

    (I'm running on CM 10.1, never got CM 12 running stable on that phone)


  • admin

    Okay, I see. DAVdroid tried to access the address book, but it seems that this was blocked by the privacy guard. At least it works now!

    I don't have any problems with CM 12 on this phone. You can try 12.1.-2015218-NIGHTLY-i9100 if you're in an experimental mood currently :grin:



  • Thanks. I might try that cyanogenmod version you suggested on the next lazy weekend ;)


Log in to reply
 

Looks like your connection to Bitfire App Forums was lost, please wait while we try to reconnect.